Unicode mapping

I’m wondering if there is a way to unicode map a hundred of glyphs at once (PUA area).
For example, selecting ss01 style and asigning a unicode range for them instead of doing it for each glyph at a time. Having 1000+ glyphs in a script font with tons of alternates characters makes it a full time job to unicode map such a font.

Any suggestions would be very much appreciated. May be if it’s not possible in Glyphs, there is a script or something that may be able to help doing it?

I did see this post Quickly name a series of unicode glyphs but the glyphs I’m talking about also have names (like a.ss01 a.swsh a.ss07… )


This would be a good task for a scrip.

I’ve almost got it but can’t assign the unicode (and cannot see the help at the moment). Somebody please finish this.

i = 0
for l in selectedLayers:
	l.parent.unicode(format(i+57344, '04X'))
	i += 1

This should work:

i = 0xE000
for l in Font.selectedLayers:
	l.parent.setUnicode_(format(i, '04X'))
	i += 1
1 Like

Thanks guys!
What should I do with the script? I’m a total noob in this kind of things…

Select all glyphs that you what to apply the unicode. Put the script in the macro window and hit the run button.

Thanks a mil! that works like a charm

Just wondering, is it possible to do the opposite - delete unicode names for several (again, 500+) glyphs at a time?

Resets unicode values of selected glyphs:

for l in Font.selectedLayers:
1 Like

Excellent! thank you!

Hello . I accidentally deleted all the of Unicode standard letters and punctuation marks . (A, B, C… a,b,c… 1,2,3… №, %, ; () …etc. ) .

I’ve used the code above but it does not give a standard Unicodes !

How to return the standard Unicode standard letters ?

For example: А - 0041

Try adding glyphs with Window/Glyph Info.

To add any glyphs, right click the entries in the sidebar. In this case the Latin > Basic, select all from the popup and hit generate.

1 Like

If I hadn’t done anything else, the first thing I would have tried would be Cmd-Z. If that wasn’t an option, my next thing would be to make sure all the glyphs with missing Unicodes were selected, then do “Update Glyph Info” from the menu bar > Glyph. Either of those would fix the problem.

1 Like

Thank you so much! Your method has helped me ! You saved me !