Unknown Error (Thread 0 crash)

Hi Glyphs team,

I’m having a crash error with the program on my computer. Not sure what is going on to be honest. I’ve included the crash log. I’ve tried the 3.1.2 and 3.2(3230), 3.2(3233). All the same issue. I’ve deleted all the Application Support, plugins and scripts, so the programs should be vanilla.

I seem to be able to open a new font file, but am unable to open any .glyphs or packages. It crashes when I do so.

Xcode version:

I started getting crashes after trying to installing 3.2 to resolve STAT table issues. For some reason both 3.1.2 and 3.2 crash now.

Any help would be greatly appreciated. Thank you for all the help!

Ok, I rebooted my computer and updated it. 3.1.2 works now but I’m still having issues with 3.2(3233) and below. Is this an issue with an OS update?

I’m currently going through the crashes tutorial. Might have missed some things to try.

If it works in the latest version, then the problem is probably solved. Why do you need that old beta?

I think it was change in app preferences that caused the crash. I deleted all of them using terminal and everything seems to be working again.