Update Error: Glyphs won't update

@mekkablue and @composerjk, the problem appeared before I installed the Murus Lite app therefore it does not depend on it. However, I will uninstall it.

@GeorgSeifert, I tried with adding this DNS and with deleting all others DNS but it does not fix the issue.

Will continue to search for solutions though.

If you’re comfortable with the command line, then troubleshooting with ping(8) and traceroute(8) could potentially help diagnose where the problem might be. I’m able to connect okay from here. Another thing to try is from a different network, in case there’s something blocking connection at that location. On your computer side, checking for proxy configs (in System Preferences > Network > Advanced for the network interface you’re using) or firewall configs (also in System Preferences > Security). Another check to try is from a different computer on the same network (a phone would count if on the same network, but could also be used to checking from another network, if turning off wifi).

Good luck.

Hi composerijk!
At the Network Utility troubleshooting with ping gave me this result:

PING www.updates.glyphsapp.com ( 56 data bytes
64 bytes from icmp_seq=0 ttl=55 time=46.126 ms
64 bytes from icmp_seq=1 ttl=55 time=33.650 ms
64 bytes from icmp_seq=2 ttl=55 time=33.894 ms
64 bytes from icmp_seq=3 ttl=55 time=33.182 ms
64 bytes from icmp_seq=4 ttl=55 time=32.632 ms
64 bytes from icmp_seq=5 ttl=55 time=32.777 ms
64 bytes from icmp_seq=6 ttl=55 time=33.325 ms
64 bytes from icmp_seq=7 ttl=55 time=35.677 ms
64 bytes from icmp_seq=8 ttl=55 time=33.635 ms
64 bytes from icmp_seq=9 ttl=55 time=43.015 ms

--- www.updates.glyphsapp.com ping statistics ---
10 packets transmitted, 10 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 32.632/35.791/46.126/4.514 ms

And troubleshooting with traceroute (again Network Utility) gave me this result:

traceroute to https://updates.glyphsapp.com (, 64 hops max, 72 byte packets
 1 (  1.506 ms  0.947 ms  0.895 ms
 2  82-137-110-2.ip.btc-net.bg (  1.693 ms  1.733 ms  1.620 ms
 3  * * *
 4  * 212-39-69-154.ip.btc-net.bg (  1.988 ms  3.232 ms
 5  sfia-b2-link.telia.net (  1.883 ms  9.528 ms  1.956 ms
 6  prag-bb1-link.telia.net (  28.723 ms  27.880 ms  28.228 ms
 7  * ffm-bb3-link.telia.net (  169.628 ms  41.294 ms
 8  ffm-b1-link.telia.net (  136.278 ms *  48.336 ms
 9  * * *
10  ae0-v100.sr-sol.sxb1.mass.systems (  34.224 ms  33.446 ms  33.504 ms
11 (  35.151 ms  32.523 ms  32.752 ms

The network is not the reason, as my laptop gets the same result everywhere. Other devices on the same network get access to this website and start downloading the app.

I tried to clear my web browsing cache; tried to leave checked and later unchecked the Proxies’ marks [e.g. once Auto Proxy Detect; later only Web Proxy (HTTP) and Secure Web Proxy (HTTPS) ]; disabled my Firewall;
Reset my IP Address and cleared my DNS cache typing into the Terminal:

sudo killall -HUP mDNSResponder

and later:

sudo killall -HUP mDNSResponder && echo macOS DNS Cache Reset

Despite all these attempts my outcome is similar: ERR_CONNECTION_REFUSED

Oddly, if I check if the website is down only for me or everyone it gives me this result even though from other devices works fine.

there is not actual page on https://updates.glyphsapp.com. So that response is to be accepted.

What happens if you open this page in your browser: https://updates.glyphsapp.com/Glyphs2.6.1-1225.html

It gives the same result:

I have the same problem.
I receive this message every time I click on “Review for Updates”:
There has been an error in data retrieval. please try again later

and I can not access this address.
I tried Different browsers / different internet connections and even VPNs.
With the same network connection, the above address is accessible on my mobile!

Hi Ebrahim,

I’m the one taking care of the Glyphs website. Maybe you (or/and others with the same issue) can help me find the problem.

If you know how to use the Command Line/Terminal.app, could you try the following commands and post the output to this thread:

1. Ping the server

ping updates.glyphsapp.com

2. Check HTTP Headers

curl -I https://updates.glyphsapp.com/latest2.php

3. Troubleshoot DNS

dig updates.glyphsapp.com


1 Like

https://glyphsapp.com does not open in my browser. By activating the VPN, I open it.
In my country some sites are blocked by filtering, but it’s unlikely that your site has been filtered!
https://updates.glyphsapp.com/Glyphs2.6.1-1225.html does not open in my browser. Even with vpn

ping updates.glyphsapp.com (vpn has been enabled)

PING updates.glyphsapp.com ( 56 data bytes

64 bytes from icmp_seq=0 ttl=64 time=0.044 ms

64 bytes from icmp_seq=1 ttl=64 time=0.093 ms

64 bytes from icmp_seq=2 ttl=64 time=0.109 ms

64 bytes from icmp_seq=3 ttl=64 time=0.096 ms

64 bytes from icmp_seq=4 ttl=64 time=0.094 ms

64 bytes from icmp_seq=5 ttl=64 time=0.053 ms

64 bytes from icmp_seq=6 ttl=64 time=0.088 ms

64 bytes from icmp_seq=7 ttl=64 time=0.093 ms

64 bytes from icmp_seq=8 ttl=64 time=0.096 ms

64 bytes from icmp_seq=9 ttl=64 time=0.092 ms

64 bytes from icmp_seq=10 ttl=64 time=0.096 ms

Um, is localhost, meaning the computer you’re running the ping command on. So, it sounds like there’s something overriding the normal DNS lookup for updates.glyphsapp.com on your mac or the other end of the vpn, or a DNS resolver.

(vpn enabled):
; <<>> DiG 9.10.6 <<>> updates.glyphsapp.com

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21080

;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1


; EDNS: version: 0, flags:; udp: 4096


;updates.glyphsapp.com. IN A


updates.glyphsapp.com. 3600 IN A

;; Query time: 407 msec


;; WHEN: Fri May 10 02:06:30 +0430 2019

;; MSG SIZE rcvd: 87

May I have run an application that has blocked my access to this address?
How can I find it?
https://updates.glyphsapp.com Opens on my Windows Pc and Android mobile (that are all connected to same network.)

The dig DNS results look correct, though. That address is what one expects for updates.glyphsapp.com right now. That’s what I’d have expected to see instead of in your ping command run.

Sometimes ad/tracking blockers will have those kind of DNS override mappings to localhost.

Did you ever install something like MacKeeper, antivirus tools or system optimizers? Get rid of them, please. They are not needed on a Mac and are known to cause more trouble than they solve.

Maybe the VPN software is interfering?

Can you try to use as your DNS server?

I do not use ad / tracking blocker app or extension!

I installed the CleanMyMac app. But the problem was not solved by uninstalling it.

I used as a DNS server, used different browsers, used a different VPN, but failed :frowning:
I am now confident that there is something on the Mac that prevents connection to your server. But I do not know how to find it

The solution is to reset your hosts file
Do it as explained in this tutorial, scroll down to How to reset your Mac’s Hosts file

feedback your result.

That is an interesting idea. Can you send us the ‘hosts’ file?