Update Error: Glyphs won't update


#1

What would cause this error? Every time I click “Check for Updates”, I get this message:


#2

Please download the app from the website: https://updates.glyphsapp.com/latest2.php


#3

@GeorgSeifert Ah, now I feel silly. Thank you!


#4

The problem is that MacOS 10.11 prevents apps from accessing web resources over none secure connections. And I didn’t realized it in time to change the URL to https.


#5

I can’t update to latest cutting edge from Version 2.3.1 (922) / Os 10.11.6


#6

Same here, and if I do a manual download to unzip it myself I get this error message:


#7

I fixed that.


#8

Solved, thank!


#9

I have the same problem for a while already.
I even downloaded a new version from the website but everytime I’m hitting the checking for update option this nice window pops up.

What am I doing wrong?


#10

If it persists, you can redownload the app from glyphsapp.com/buy and update again.


#11

Hi there!
On my personal MacBook (model 2017; MacOS Mojave 10.14) , I am getting the same problem with an update error from File/Check for Updates (the same message with only possible Cancel Update button).
But unfortunately, I can not download the update either from the link https://updates.glyphsapp.com/latest2.php
nor from the website: http://glyphsapp.com/buy. In both cases, I get an ERR_CONNECTION_REFUSED message.
This problem appears no matter which type of internet access I have (i.e. does not depend on my internet connection); no matter which kind of web browser I use (Chrome, Chrome Incognito mode, Safari, Firefox); no matter if I have turned off or on my firewall and deselected all check marks on the Proxies’ Protocols (Network/Advanced/Proxies/Protocols).
On this Proxies tab, I tried as well to delete the default domain for Bypass proxy settings for these Hosts and Domains as to deactivate the check mark on Use Passive FTP Mode (PASV)

This is what I get using Chrome and Chrome Incognito mode:

This is what I get using Safari:

This is what I get using Firefox:

The last time I had to download the app from my phone and send it to the computer. Do you know by chance how to fix this issue?

Best,
N.


#12

It seems to be a problem with the https connection that your macOS has a problem with the certificates of the server.
Have you tried with a different user?


#13

I just made an other User administrator account on the same MacBook and it gives me the same messages on both Safari and Chrome (plus Chrome Incognito) as they were on the main User account.
If you are considering an issue with certificates of the server on my macOS what could you advice me to do in order to fix it?
Thanks,
N.


#14

Can you try it in the Guest account?


#15

As I see from the User’s panel when the FileVault is turned off (as it was by default) it allows to the Guest user only accessing Safari.
In the Guest user the moment I try to download Glyphs app it brings a message that there is no free space on the hardrive.
Currently, I turned off the FileVault but it shows me the decrypting would take at least 2 hours.

UPDATE:
The decrypted (turned off) FireVault enabled me to access softwares more than Safari in the Guest account and to download files. However, at Safari and Chrome it gives exactly the same messages, as I stated them in the first post.

So what to do next?

Best,
N.


#16

Do you have a third-party tool monitoring the network connection? Little Snitch or one of the system maintenance tools?


#18

Yes, I just installed Murus Lite, an alternative of Little Snitch. Is there anything specific that I should do with such an app?


#19

Deactivate it.


#20

One thing you could try is to use a different DNS server. 1.1.1.1 is a good option.


#21

It’s possible that the Murus Lite firewall config is set to block outgoing connections for this. Perhaps Murus Lite shows something in the logs when you try to connect to glyphsapp.com or updates.glyphsapp.com.