"Update Features" removes all my Features?

Hi there
I’v updated to the latest version of Glyphs (3.2 - 3228) and when I press “Update Features” all my features are removed.

See screenshots:

After it has erased all the features, I’m not able to Compile or Update features?
Has anyone experienced the same? or know how to fix it?

Works for me. Do you get a different result when you click the update button in the feature panel?

Yes. That’s a work around. When I use the update button in the features panel it just say this:

I cannot reproduce the error with other files, so it seems like it’s something with the Glyphs file.
I’ve sent it to you. Could you try the update buttons and see if you get the same result with that file?

I fixed the locl feature.

But what do you need the “commaaccentcomb.loclMAH” for? It should look and behave exactly like the normal commaaccentcomb?

I don’t need it. But it has been generated automatically as most of my features are (see the file I send).
But now when I press “update features” in the bottom button all my features disappear. When I use the panel I get the script error you describe. Could you please let me know, what to do?

It may sound like a joke, but have you tried turning it off and on again? I’ve had the same thing happen to me randomly a handful of times without clear reason and no way of reproducing the error. After relaunching Glyphs, all worked as intended again.

Hi @raoul thanks for the response.
I’ve just tried it, and I get the same result :frowning:

The glyph is in the default glyph set of the “Oceanic” languages. From what I can tell from Wikipedia, that glyph should use a cedillacomb as component. Marshallese language - Wikipedia
But that article suggest that we need more alternates: Lcommaaccent.loclMAH, lcommaaccent.loclMAH, Ncommaaccent.loclMAH
ncommaaccent.loclMAH (all four are in confusion if they should use a cedilla or a comma. Most (European) languages need it ot be a comma, but Marshallese needs a cedilla).

I still have the issue that it removes all features when use the bottom “update features” button. But a temporary workaround is to use the features panel. But then it automatically generates this code:

languagesystem dflt dflt;
languagesystem dflt MAH;


script dflt;
language MAH;
lookup locl_dflt_0 {
sub commaaccentcomb by commaaccentcomb.loclMAH;
} locl_dflt_0;

All the functions has some sort of error. I’ve tried to uncheck “Generate features automatically” and then remove them, but it still displays errors.

What to do?

I fixed the feature code generator so this will work with the next version.

Until then, remove all lines that contain “script dflt”.