Using F-keys for shortcuts

Is there a way to use the F-keys (F1-F12) for custom shortcuts? I like using those in Adobe apps but can’t seem to record custom shortcuts using Fkeys in Glyphs 3. :sob:

I fixed it.


This is a wonderful addition. Can it support more? Wikipedia says up to F19 are physically available in some keyboards but Unix X Window systems seem to support up to F35. I can see the benefits of keys that cannot be pressed by mistake from a standard keyboard (i.e. macro pad).

1 Like

Thank you so much!

I think I added till F15 or so. I’ll can add the rest if needed.

My extended keyboard has F keys up to F19. F16 to F19 above the numpad.

Added all of them.


Tried to bind f1 to Undo to test it. It works until I quit and reopen the app. The shortcuts reset to default.

It works for me. What version of MacOS do you have? And just to confirm, other shortcuts will stay around?

Big sur 11.2.3. I tried f1=undo f6=save f7=save as, made some shapes to undo, and all fkeys (except f11) did the undo task. Quit the app, reopened, checked shortcuts, and save became f5 while save as and undo became blank. It’s weird. I guess I won’t use the fkeys for now.

Can you try to assign a different shortcut like Cmd+Y? And check if that sticks around?

Same. Tried undo=cmd+y, it worked until I reopened the app. It went back to default, cmd+z.

Not sure if it’s related, but I assigned F19 and F20 to commands and they do not show up as shortcuts in the menu, and pressing the keys don’t do anything either (other custom commands are fine). At least the Preferences shows the key names and actually remembers them though.

Add: Using F1-F12 works, though the key name does not show up in the menu. Mac actually uses F14 and F15 for screen brightness control. I have given up on using F13 and beyond at this point.

Add 2: I said F1-F12 works, but it seems F1 and F2 results in the same keypress? Actually this happens in any combination of F keys: Assigning F1 for About and F4 for Check For Updates, and try both, only F1 seems to be called.

I fixed a few issues. I can’t test keys above F12 right now so I needed to guess a few internal values.