V.787 Curious crashes

Just updates and it seems like the latest cutting edge version is crashing a lot more than my previous (782) when working with glyphs that use components.

Anyone else on the same boat?

  • Good to mention that the crashes multiply when working in text mode and trying to enter drawing mode by double clicking on a glyph.

So far 10 crashes in 15 minutes.

*** Just downgraded to 782. Problem solved.

Yep, same thing here :).

Try update to (787) and check if the behavior persist. :smile:

I can confirm that the latest version was the source of problem, because the issues ceased after the mentioned downgrade. Up and running without incident ever since.

Experiencing more crashes in the latest version too. Not in the same way as Ralist says though.

The recent few days after updating to version 787; Crashes occur by double clicking any glyph with the arrow- select “V” tool while placeholder is active (Not in the main window)

Confirmed. I forgot to mention that I also had /placeholder activated. Sounds like an important bit, but go figure. Good that @Avantino spotted the culprit.

Van you check the update that I just published.

Just submitted four (4) crash reports using [788].

There is a minor bug with the Font Info panel in versions [787] and [788].

When the Instances tab is active, the window width cannot be resized — it appears to be a fixed dimension, and very wide. All other tabs in the Font Info panel allow the window to resize.


The newish floating Preview Panel doesn’t appear to show anything. Is this feature only meant for external displays, or should it work with one too?

Using OS X Yosemite

Fixed it. Please get the update.

it starts showing something if you edit a glyph.

fixed that.

Awesome! Thanks Georg.

fixed that.

The behavior is the same in version [789] — doesn’t appear to be fixed.

Do you have any View plugins installed?

Did the lastest build (789) stop importing kerning?

in what circumstance?

I opened an existing otf font to edit it and the kerning did not import. To be fair, I was in the middle of working on something, so as soon as I saw the kerning didn’t import, I reverted to the previous version and continued on. I haven’t tested to see if that happened with any other fonts. I asked, because if I was the only one that that happened to, I would install and test the latest build again when I finished the job I was working on. If others experienced the same thing, then I’d hold off updating.

Georg…just want to leave feedback to say you killed this bug in build 791. Thank you very much!