Variable font bracket layers problem

I have a problem exporting my variable font, I’m using the alternating shape with the bracket, all of the layers seem fine, but when I try to export it says that the letters aren’t compatible.

It is evident that layers 0 and 100 are not compatible.

I don’t see where I did wrong in my points, they seem to be even. Even if I copy and paste the exact same shape in layer 100 or vice versa they still seem disconnected.


It currently does not check compatibility between the first and second master. Can you either:

  • add an instance between the first masters in Font Info > Instances
  • or add a custom parameter called Enforce Compatibility Check to Font Info > Font

I tried with both, with another instance it adds the connection, when exporting it still gives me an error same with Enforce Compatibility Check.

It is possible that the transition is too complex for a TrueType conversion. See if there are curves you can replace with line segments in both masters.

Thank you! I tried adding more layer and now it works! Is there a way to remove some of them but still working?
0[100], 0[200], 100[200], 300, and 300[100] appear disconnected but it seems that I need them in order to not have the error again.
Since each bracket is used to remove points for each master I thought I could just skip the layer for the master before.

This might be a small thing that I am missing. I have been working on a variable font, the screenshot you shared above with pale green uppercase 'A’s, is actually helpful to view the glyph. Can someone help me how to open that view?

View > Show Master Compatibility

1 Like

Perfect. Thank you so much @birdland