Variable font, corner components and remove overlap problem

If I understand the learning section about variable fonts right, I have to use the export parameter “PreFilter: RemoveOverlap” for correct applying of corner components.

But doing this will cause errors on export, because removing the overlaps of other components will result in incompatible masters.

(one example: in the fat one, the bar cuts the node behind it.)

Is there any solution, e.g. only applying the corner components and not the other ones? Or did I made a mistake?

3.1.2 (3151)

Generally, you don’t remove overlap for variable fonts. Where did you read this?

In the leanring area: Variable fonts.

And because my corner components do not appear at all, I thought, I have to use this custom parameter. (“they have to be applied before interpolation”). Was just a try. But maybe I understood this wrong…

Where do the corner components not appear? Only in the exported font? What do you see instead?

Yes. No corners in the exported font. There is simply nothing. Yust the pure font without the corners.

Hups, there is also nothing in standard .otf files.

Solved. There was a “Remove Glyphs:_*” parameter in the export. This should better not be used with corner components. Sorry for the confusion.