Variable font not working in Illustrator

Hello Georg, I’m playing around with a variable script font. So far I just have one axis but it’s not working in Illustrator - but it does work using Rainer’s Variable Font Test HTML, AxisPraxis and It’s as if it’s not updating the sidebearings in Illustrator, which is really odd!

My custom axis is Tracking TRCK code in the custom parameter. Right now I’m not adjusting weight or width, just the tracking. I have two masters and three instances. Tracking goes from 100 to 900. Any help would be great. I’ve gone through the tutorial about 3 times and still can’t figure it out.

How it looks on Axis Praxis:


How it looks in Illustrator:

1 Like

I am afraid to say that Illustrator’s implementation is somewhat buggy. If it works in a web browser, you know the font is OK.

Have you tried renaming the axis to the standard width? I mean simply ‘wdth’.

Can you move the outline in the wider master up a few units and check if that helps?

Hey guys, thanks for the responses and help.

I moved all the glyphs up by 5 and then 5 again. The slider is showing the movement upward from ‘condensed’ to ‘wide’ but the right sidebearing still isn’t changing.

Getting rid of my ‘tracking’ parameter and just using width also didn’t work.

Any other thoughts? Seems like a super weird glitch for Illustrator to have.

Have you tried the Decompose parameter?

:weary: That didn’t work either. I reached out to Illustrator to see what they think (I’m assuming they will have no idea though…)

Any other thoughts?

I’m also very interested in a solution to this issue! I was convinced I was doing something wrong, but testing my script font in a browser based variable font tester worked perfectly… I hope adobe will get it together soon!

Should work in the current version of Illustrator CC.

1 Like