Variable Instances PostScript Name in Glyphs 3

Hi there,

I’m having difficulties with the PostScript name of my named instances when exported with Glyphs 3. I exported the same variable font (created in Glyphs 2) from both Glyphs 2 and Glyphs 3. While the Glyphs 2 export shows a PostScript name consisting of Family Name and Style, the Glyphs 3 export only shows up the Style name (see screenshots). Which leads to an error message in Mac’s Font Book as soon as you have multiple Variable Fonts with the same style names — I guess not that uncommon to have Regular and Regular Italic instances in almost all fonts.

Glyphs 2 Export (see PostScript Name):

Glyphs 3 Export (see PostScript Name):

How can I make sure that my named instances carry the Family Name in the PostScript Name?


Can you try the latest cutting edge version (activate it in Preferences > Updates)

Can’t get the Update running. This Monterey-Update messed severely with my machine.

»Beim Entpacken des Archivs ist ein Fehler aufgetreten. Bitte versuche es später erneut.«
Tried multiple times already. Will try a restart.

Any idea whether this is fixable? Tried restart the app and the computer multiple times but still getting this error message. Receiving the same message on OS Monterey and OS Sierra.

Bildschirmfoto 2021-11-22 um 15.53.38

Not sure why the update does not work, but you can also download the latest cutting edge here and replace the current Glyphs app in your Applications folder:

1 Like

I fixed the update.

1 Like

Thanks a lot Florian & Georg! Worked for me. Also the export is running smoothly now. :pray:

Thank you Georg!