Webfont export doesn’t work

Hej, I made a handwriting font in glyphs and somehow I can’t manage to export it as webfont. tried all formats (eof/woff) and renaming already. would be nice if someone knows a solution.
Funny enough an earlier built worked perfectly fine.

It is an allcaps font and I put our logo at all lowercase slots, maybe that causes the trouble?

Any tip appreciated, thanks,
cheers from amsterdam,

dropbox link to woff font:

What exactly doesn’t work, which app version are you using, and can we have a look at the .glyphs file?

of course here’s the source file:

I can export all kinds of webfont formats but none is properly shown if using on the www.
As mentioned before the earlier built functioned well.

Thanks for helping!

I had a look at your file. There are a few issues with the file (wrong codepage and unicode range settings and the paths are a bit too rough in places). But exported with the latest cutting edge version, the font works in Safari and Chrome.

And with the latest cutting edge version, you can simply delete the lower case and Glyphs will automatically double encode when you do “Glyph > Update Glyph Info” (there is a small bug that assigns a wrong unicode to Idotaccent, so you need to remove that manually).

Hi, thanks for your time and advice, I updated the software and delete the lower case, but still no working woff.
weird. the other issues you mention are new to me, (wrong codepage and unicode range settings) could you perhaps provide links to helpful forum entries to solve these errors? Thanks again.

You can just delete the parameters and let Glyphs calculate them automatically. And this:

And this tutorial: https://glyphsapp.com/tutorials/creating-fonts-with-complex-outlines

Hello Gregor Thanks for the handy tutorial, I’ll run through it.
One last one: what parameters do you mean?
‘You can just delete the parameters and let Glyphs calculate them automatically.’

Thanks again

I meant the unicodeRanges and codePageRanges paremeters.

Hello, I deleted the parameters and followed the tutorial ‘fonts with complex outlines’.
Saved the font under a new name and expoerted it. Still the desktop font works fine, woff doesn’t.

Could you have a brief look at my exports?


What do you mean by ‘the WOFF doesn’t work’? The WOFF is fine except that it does not contain lowercase letters.

Thanks mekkablue. sorry for being inaccurate, export to woff works fine but it isn’t show if uploaded to a web project.
Gregor advised me earlier before to erase the lowercase since it is an allcaps only font.

What happens, if you use the .otf as webfonts?

doesn’t work unfortunately

Then your CSS is probably flawed because the fonts are fine.

Don’t only delete the lowercase, but also update glyph info for the uppercase. Then both lowercase and uppercase will be mapped to the cap glyphs.

Dear Georg & Mekkablue,
thanks for helping me out, now the the webfont export work like a charm. Learned a lot (simplify complex outlines and stuff). Amazing to be able to rely on the forum.