Weight and Width Interpolation in same file?


#1

Hi All

How do you interpolate across two axis in one file? Glyphs 2.5.1 has moved ahead of the tutorials on Master and Instances set up with the use of Axes Parameters, so I’m not sure about best practice.

I currently have threes masters:: Regular, Regular Condensed and Bold. I can easily interpolate the Weight from the Regular to Bold and Width from the Regular to Condensed but I’m having trouble setting up the masters and instances up to do both. Is it possible? I’d also like into interpolate a Bold-Condensed if possible.
I’ve tried adding Axis parameters for both Width and Weight but only the top one shows up in the master’s Axis coordinates.

Any help much appreciated.


#2

Set up two axes with the Axes parameter in Font Info > Font, choose Weight and Width (predefined options), then take care of the settings in Font Info > Masters and Font Info > Instances.

Sample setup:
Regular: weight=80, width=100
Condensed: weight=80, width=75
Bold: weight=160, width=100

Usually I recommend the average stem thickness for your weight value, and for the width value, I recommend the average overall width percentage compared to the Regular. So, width=75 means that a text set with this condensed is about a quarter shorter than the normal width.

That would be an extrapolation. Simply create an instance with appropriate values, and if you want to have it as a fourth master: select it in Font Info > Instances, and pick Add Instance as Master from the pop-up menu in the bottom left.


#3

Thank you @mekkablue That makes sense.

I’ve set up the Axes parameter in Font Info > Font, as described however only one Axes Coordinate appears in the Master tab (whichever is listed first in the Font > Custom parameter field). Is there a way to see them both Weight and Width or am I missing something?

Thanks again for your help.


#4

Can you send me a screenshot of the Axis and master Settings? It might be a problem with the version you have.


#5

Ah, yes. To update to the latest cutting edge version, enable both checkboxes in Glyphs > Preferences > Updates and click the Update button.


#6

Sure, here you go.


#7

Ah, OK. I can do that. Is the current cutting edge version pretty stable?
Thanks


#8

Only add one Axes parameter that contains both axes.


#9

Yes.


#10

Thanks @mekkablue and @GeorgSeifert
Yes, didn’t realise I should add both axes under one parameter. All the working perfectly now.
Much appreciated.