Weird interpolation result for letter k

Corrected path direction and shape order but the instances are weird. Also exported as VF, tried on fontgauntlet and result is different (still weird)

test.glyphs (14.1 KB)

Hi, what’s the deal with your intermediate layers? You have two intermediate layers at {120,0}. If you remove them, the interpolation works as expected. I don’t quite understand why you have those layers.

First, you shouldn’t have two layer on the same spot.
The set the width coordinate of the remaining intermediate layer to 5.
Or, remove the Width Master altogether.

I might be that some of the hassle comes from importing a file form Glyphs 2.

@SCarewe I don’t quite understand why you have those layers. Me neither :smiley: They were not supposted to be there. I might have missed to remove them at some point.

@GeorgSeifert I got it. It was created in G2 and I started working on G3. Do you think those intermediate layers may exist because of this conversion?

Thanks for the help!

Do you have a file as it was before you opened it in Glyphs 3?

Hi guys,
I deleted duplicated intermediate layer and set undeleted as {120,5}.
Also I deleted some —no base glyph— from background.
I hope that helped you.
test-k-solved.glyphs (13.3 KB)

Screen Shot 2021-09-06 at 19.08.38

1 Like

Checked the older file, G2 is not guilty. Sorry I missed it.