Weird shifting in layer font

Hello all,

I am building a layer font and I have a super weird problem I never experienced before. Using Illustrator CS6 to test my font I found that when I type using the Paragraph text box (click and drag to make the text box) to type some text, then copy/paste in place and change the style, this new upper style text shift a bit up. This is NOT happening when I type text just by clicking text at a point.

Weird shift with —>
Correct using —>

This is so annoying and I can’t figure out where is the real problem here… Anyone experienced this before?


Plus, the shift is vertical, like “5px” above.
I tried on Illustrator CC with same issue. Also as a note, I am testing the OTFs by exporting them to the Adobe/Fonts folder…

Update… I tried making a new file, copy some characters and the problem dissapear… so the file is corrupted somehow :frowning:

This is because Illustrator determines the height of your first line by the height of your d. You can change that in the text preferences.

Sorry, “your d” ?
Mmmh, why this is not happening with other layered fonts?

In any case, I just reset (deleted) the Adobe Illustrator Preferences Settings ( and the problem persist.

You need to set the baseline shift to “Fixed” for all layers:

I will add a paragraph about this to the tutorial.

You suggest me to maybe add this post to the typeface manual when release? :stuck_out_tongue:
I have another problem, I think the files are corrupt bc i dont have issues with other layered font

I added some paragraphs about this in the original tutorial:

Thank you!

Quick question > is this a problem with how Glyphs exports? I have bought a layered font and this is not a problem at all.

No. It has to do with how AI calculates the baseline offset in an area text object. It is not a problem if the d has the same maximum y coordinate in every layer, and the font you bought probably does exactly that.

Again, please read the tutorial, the problem and its solution is described there:

Ok so, what if I change the x-height or cap-height so every shape in each layer hits the heights. Thats possible?

Also, I tried your second solution; added a 1x1 shape in every layer at same place inside ‘d’ with no luck, the squares also shifts.

How are you testing your fonts? Are you using the Adobe Fonts folder?

You can also send me your .glyphs file to res (at) (this website without www).

There is something I don’t get. I make a new file, copy and paste my ‘d’ from my font (which shows shifted) make a new shadow layer, paste shadow (not same height), export (to adobe fonts folder) and works fine, using text area tool, default settings…

This is most likely an installation and/or font cache problem. Are you using the Adobe Fonts folder as I suggested in my last post?

Yes, I am using that path, I deleted them, restart, export again, same.

From the e-mail you sent me, I assume the problem was that the d did not have the same y maximum in all layers, after all. Were you able to solve your problem, and can we close the thread?

I did - thanks for all!