What if I want /fi to be in #dlig feature?

I’ve added .dlig suffixes to f_i and f_l ligatures, but both U+FB01 and U+FB02 still force themselves into #liga.

Is there a way to prevent this without disabling auto-generation?

f_i and f_l already go into dlig by default; fi and fl go into liga.

So I guess I’ll just uncheck /fi and /fl

Right. You shouldn’t have both fi and f_i (resp. fl and f_l) in the font at the same time.