When I Create Outlines in a CAD or Adobe program, why do I lose the anchors I created in Glyphs 3?

When I drew my glyphs in Glyphs 3, I tried to use as few anchor points as possible. When I pull the font into CAD software (Rhino), or when I “create outlines” in Adobe Illustrator, I end up with way more anchors. Am I doing something wrong? Why does it seem I’ve lost the information within the font I made?

The anchors as I drew them:

The anchors I get after Creating Outlines in Illustrator:

The anchors in Rhino:

This is because you are expanding TrueType outlines. Don’t worry, this is the normal behaviour. Is it posing you a problem?

I should mention two things regarding terminology:

  1. You are not losing anything. Technically, you are even gaining more nodes. The outlines are absolutely identical to the ones you drew in Glyphs, it’s just a different mathematical model of representing them.
  2. You’re not losing “anchors”. In type design, anchors are the red dots you use to align components (accents etc.). You’re talking about nodes (or points). The “anchors” are called oncurve nodes and the handles are called offcurve nodes, although you can also say handle.

In Rhino, some of the points that are being created are too close to each other to work with and require a small amount of effort to adjust. Not a major problem, but a nuisance nonetheless.

A .dxf or .dwg export would be solve the Rhino situation. It sounds like it’s perhaps unavoidable for Illustrator?

(Thanks for the clarification of terms!)

If you export as otf, this won’t happen.

Have you tried just copy-pasting the outlines directly from Glyphs?

It is possible to write a .dxf export plugin. Do you have a .dxf file in a format you like to export to? Is there any special format for font data?

I had not ocnsidered trying that! Both of these seem like viable solutions for me while being relatively easy. Thank you! I’ll try them and see if they work before taking the .dxf route.

I initially exported this as .ttf rather than .otf because I was concerned about having “PostScript/CFF” selected in order to use .otf. Adobe programs have stopped supporting “apple script text.” Is that what this is? Or will an .otf export work just fine?

OTF will work. What’s not supported anymore is the old PostScript Type 1 format.

Ah I see. Thank you

I exported as .otf and tested in in Illustrator. However, when I Create Outlines I’m still not receiving the same nodes I used to draw the glyphs. If this is something others have had success with before, am I perhaps exporting incorrectly?

What do you mean, you don’t get the same nodes?

Uncheck the “Remove Overlap” option on export.

Did you follow this: Testing your fonts in Adobe apps | Glyphs ?