Why is this point not in my undo history?

I was working on a vectorised glyph by removing curve points and I must have clicked something wrong, but for some reason the point isn’t in my undo history and I can’t undo it. It’s happened once or twice and I have no idea why it’s happening.

Any idea what I might have clicked that created this distortion?

I’m using Glyphs Mini.

This happens when the coordinates get corrupted. Sorry about that.
If you can reproduce it, I can try to fix it.

Now I see, it seems as if all the end nodes in the outline were replaced with the intermediate control points.

For this glyph I thought I’d rather clean it up in Affinity Designer instead.

At least now I know it’s a bug and not a feature.

Do you remember what you did just before this happened?

Not really, I was working on a rather detailed font that’s taking me a lot more time in the early design phase than my other projects, so I’m trying to find an efficient workflow.

First I tried drawing everything with the details using Calligraphr, but then I found that even with that I got intersecting coordinates and buggy outlines.

Even tracing by hand proved to be too much work for this so I tried another approach which was to only draw the outlines in a Calligraphr template, clean up the glyphs and then use components to have one for the outline and one for he “zebra stripes”.

It was in the stage when I was cleaning up the autotraced outlines by deleting all the extraneous nodes that the bug happened, it was as if I hit a wrong key on the keyboard or clicked a wrong button or something, but undoing the action didn’t change anything.

This is about as much context as I can provide.

(By the way, the 1 image upload limit for new users is a little annoying when trying to provide context here, I had to combine all the smaller screenshot into one collage to post this)

I increased your trust level.

I’ve managed to come across the bug and a similar bug a few times when working on another project, in both projects I’m using components quite a lot in the early stages of the design.

I have a screen recording of it happening, but the forum here doesn’t seem to support that so here’s a screenshot instead.

It happens when I create a component glyph as a copy of the glyph and try to set the side bearings, it then sets all the coordinates to zero.

Snufkin.glyphs (161.5 KB)

Can you post a dropbox or wetransfer link of the screencast?
If you can reproduce the problem, then there is a good chance that I can fix it.

Here’s a link. I already shared the project file, it happened consistently with the lowercase a glyph when I tried setting the side bearings.