Windows error: "does not appear to be a valid font"


#1

A few of the OTFs exported from Glyphs aren’t being recognized by Windows. But only the first four light weights. The specific error is “does not appear to be a valid font”. Here’s the glyphs file:

http://cl.ly/3Z2W0X1j2M0E


Not a valid font file
#2

I am not on my Mac now but my guess is that the family name is too long for Windows. Try shortening it to 20 chars or below, e.g. by using Cond instead of Condensed.


#3

I had the same issue. For some unknown reasons, some longer names are automatically shortened by Glyphs, others not.

My solution:

  1. in Instances, give a short name to let “family name” + “instance name” < 32 (spaces included)

  2. assign a custom parameter “preferredSubfamilyName” the full name of your Instance

  3. option: set a “filename” custom parameter if you want to keep it coherent with other exported files.


#4

Customer gets “Not a valid font file” warning- on Windows 7
Tried OTF and TTF - same warnings.

I installed the same font on my Windows 7 - works perfect.

Not%20a%20font


#5

You can try verifying the font file with Font Validator.


#6

I did it and Font Validator warned me:
-Few missing glyphs
-DSIG table is missing

Reported Error of:
-The version string is not formatted correctly

Could this be the reason for one Windows machine rejecting that font?


#7

I do not know for sure, but I would try fixing these issues and send the updated font to the user. It is also possible that the problem is not the font, but the user’s set-up.

If it is the font, it’s probably the missing glyphs, I guess. Make sure at least the 1252 Encoding is covered. You need DSIG for OpenType TTFs, but Glyphs adds an empty DSIG automatically when you export a TTF.


#8

Thanks - I will try that and update.


#9

OK - found the bad guy in this case.
here is the reason as well as the solution. Thanks guys-


#10

Windows - go figure…