4 axes – 3 Masters

I have a font with 4 axes and 3 Masters. In previous versions this didn’t seem to be a problem, now I’m in trouble when exporting a variable file (OTFs etc are fine). I’m getting the following error message:

Problem generating Feature Variations
In glyph: notdef: Master is outside of the interpolation space at 100 and axis rage: 0-0

Is there a way around this?

Can you show you masters setup?

Yes, here they are.

This setup has two axis, not four.

And the “Pre 5th” master seems to be the only one suitable to be the origin of the variation. Add a “Variable Font Origin” parameter to the font settings and pick that master.

And update to the latest cutting edge version.

And the Axis Location parameter is not needed if it has the same numbers as the Axis Coordinates.


I have the same issue when exporting a variable using Glyphs 3.3 (3309). I already set a Variable Font Origin in Font > Custom Parameter and I have 4 axes (weight, italic, contrast, slant). It seems not working since I added the slant axis, it worked well when I had 3 axis (weight, italic, contrast).

I hope you can help.


Can you show your master setup?

Why do you have an Italic and a Slant axis? What does one do that the other one doesn’t?

I need the slant axis for Figma and keep ital for Microsoft.
Is this what’s causing the issue?

1 Like

How do you have those values set up?

What do you mean by “keep ital for Microsoft”? Are you talking about style linking?