A way to Copy-Paste multiple Glyphs from one file to another


#1

is there a way to Copy-Paste multiple Glyphs from one file to another?
with the spacing parameters being kept?

thank you!


#2

Copy, paste.

What is a spacing parameter?


#3

i meant keeping the spacing values… from right and left of the glyph

thank you for your reply
what if i want to replace the existing glyphs with the one i pasted?
because automatically it creates extra ones of the same glyphs


#4

Do you mean the sidebearings? They are kept when you copy and paste.

Edit > Paste Special (hold down Option key) and pick your options.


#5

One bit wasn’t mentioned: All the copy pasting has to be done from in the font view.


#6

Copy pasting glyphs does not work in the latest beta version. Proper LSB and RSB values are ignored and only values of the first master are copied from one font to another one. Scripts for copying sidebearings do not work neither. (In version 2.4 everything works as expected.)


#7

thank you all


#8

I just tried and cannot reproduce this. Everything worked as expected for me in Version 2.5.2 (1158).

Update: Do you mean Paste Special rather than Paste? The fact that only the first master info was copies could be linked to the Content of active layer option.


#9

Please check the files I sent to the support email. I am convinced there is a bug in the latest beta, because in 2.4 everything works as expected.


#10

Yes, I can reproduce it. It takes the metrics of the second layer even though you are trying to copy the fourth layer. Thanks for reporting this!


#11

The copying of metrics is not to be used in this context. If you use “content of active layer” then the metrics are already there.
The metrics needs matching masters in both fonts. it is useful to copy the spacing from the upright to the italic. And it should not allow to select all three checkbox, because that is not possible.


#12

@GeorgSeifert It means, there is no way to copy one glyph let’s say from font One layer 2 into font Two layer 1 while keeping LSB and RSB unchanged? Seriously? (Nevertheless, if I do it now, the task DOES copy LSB and RSB, but from a different master.)


#13

Yes, there is. Just disable the three metrics checkboxes.

The mapping from the masters of the source to the master of the target is difficult. Now it just uses the index, first master to first, second to second…


#14

Great, thanks, it works. It is little bit confusing to uncheck LSB/RSB checkboxes to actually copy LSB/RSB but this will make my current job much easier! (I am turning a family of several masters into a variable font, so I only copy certain layers.)


#15

You could also duplicate the whole file and then remove the masters you don’t need. Should be faster and less likely to miss something.


#16

This is a more complex issue, I use different sources to build the one file.


#17

OK then.


#18

hey… still having problems with this subject…
wonder if you could help me.
i tried to copy number of glyphs from one file to another, with the “paste special” function,
the thing is that it seems that i cannot choose to which master the glyphs are copied to.
it always pasted them to the same one, no matter in whice master the font view is showing.

what can i do?
thank you


#19

Did you try Contents of active layer? What you are trying to copy is a layer, not the whole glyph, it seems.


#20

i dont know what active layer means.
i marked the glyphs and pressed CMD+C
how can i copy the whole glyph? should i be doing something different?