Can't open an OTF file exported from Fontself

Hi there. This is my first post here !
I’m not a professional type designer, but a furious font lover.
I’ve only made one font so far :
http://www.grootfontein.net/?portfolio=lemontwist-is-a-font-i-designed-its
… But I’m working on a new one ! (a handwritten uppercase)

And I have some problems right know :

I work with both Fontself and Glyphs Mini. Fontself is really a time saver when it comes to creating handmade stuff. Glyphs is really helpful to see/solve issues like contour intersecting itself.

So I’ve worked using those 2 tools on my new font… until today : Glyphs Mini doesn’t open the exported OTF file from Fontself anymore…
I just got this strange message :

Error while reading the document. (***-[NSArray subarrayWithRange:] range {0, 250} extends beyond bounds [0 .. 247])

I didn’t see any similar error message in the forum, so here I am…
I’m pretty sad because Glyphs Mini is my only way to know what glyphs are not right using the Correct path direction or Remove overlap functions.

I hope some of you guys could give me some advice !

Here is a preview of the font (pardon my french :smile:)


Thank you !

I kept working on the Fontself file, and re-exported the OTF file… and now I can open it again in Glyphs Mini !
So that problem is solved :smile: but I have another one if you guys could just take a look:

The problem is a glyph with the name “ét.liga”. It is not handled well in Glyphs. I’ll fix but you should rename that glyph. Glyphs names should only contain ascii chars.

Thank you Georg, I’ll try that. :pray:

On glyph names:
https://glyphsapp.com/fr/tutorials/getting-your-glyph-names-right

You guys rock :smile:

I checked the file in Fontself, andhe glyph names seam OK…


Even in Unicode :

The font contained one glyph ét.liga. Quite at the end.

Thanks Georg.