Crashes in El Capitan

I found some crashes related to internal system functions from El Capitan. I can’t advice to update the OS at the moment.

(and I had some very strange graphical glitches while watching a movie on 10.11 on my test machine. It seems we need to wait for updates from Apple)

Are the latest Glyphs updates related to the version of the OS. Meaning that if I run 10.10 on my machine can I still update to 814 for example and expect everything to function as it should? Or are the latest Glyphs updates OS specific?

They require 10.9.5+. Nothing has changed in that respect.

I experienced serious problems with Mac OS 10.11.
I further recommend not to upgrade to El Capitan if you still wish to work with Glyphs.

10.11.1 is out. Relavent bugs fixed?

Too late, I’m using El Capitan 10.11.1, and Glyphs 2 simply refuses to open… bizarre
any ideas?

Move your plugins folder to the desktop and start again. Redownload the plugins from GitHub.

Hello all:
. . . just starting out here with Glyphs (and sorry to start out with a crash report). I was pulling some handles about when OSX (10.11.1) went down like it was 2001 again – i.e., like a power cut. It took two power-on cycles to get the thing going again.
There is no crash report in the usual place (~user/Library/Logs/CrashReporter) – is there somewhere else that I can look?
Otherwise, everything is lovely . . .
Cheers, C

The most common crash is with some strange method deep in the system document saving code. I can’t reproduce it reliably. Thats why it crashes during normal editing. It is the autosave in the background.

Was this problem solved?

There is still one problem that it might crash during autosaving. I’m working on it.

Georg, so while you solve this auto-save bug, is it possible to disable it? or you don’t recommend that?

I will live with the crashes; so far I haven’t lost any work thanks to auto-save.

Me too George, but if the auto-save is the reason for crashing, you might not need it.

Yep…some serious problems on 10.11.

I clicked “show images” and Glyphs froze, force quit, and re0pened and this is what I see. Even after a restart.

I had the same issue, and I solved the freeze that you show pressing the “esc” key.
May be possible a problem with linked images?


Yep, that fixed it. Thanks!

Other than that, it’s been running pretty good on El Capitan for me. The occasional crashes, but overall it’s been actually better for me on El Cap than Yosemite.

This is a stuck dialog that interferes with the redraw of the window. Esc cancelled the dialog.

I have this problem when the file have an image as background and don’t find it.