Diacritics works when typing on GlyphApp but not after exporting

Hi! I am new to Glyphs, I made a font which has accents, when I am typing them in GlyphsApp they work just fine, when I export OTF the character  works fine but the à doesn´t. What happens is when I press tilde it changes for another font installed in the system.

I am producing ALL CAPS only for now.

I checked if this was cache problems but it isn´t I am using only in the fonts folder from Adobe. (I did the process from the tutorial).

PS: I searched the forum too, but maybe I don´t know the exact keyword for this problem.

Thanks in advance =)

You need to have a tilde and tildecomb in your font. The first is there for when you type the tilde and then the letter (it shows in a yellow box). The tildecomb is typed after the letter and is positioned with anchors.

And read this:

I got it working as you said it inside Glyphs, when I type tilde (the yellow box appears) and after I type A I get the Atilde(as well all other characters with diacritics).

After I exportedI I also got it working for Aacute and Eacute (just tested this two glyphs) but when I try tilde + A the font changes to another font(in this case changes to helvetica).

I did the process for cleaning the cache and I am using fonts in Adobe Apps.

Thanks again.

That means that the character is not supported by the installed font. IOW the font does not have a glyph linked to the Unicode value in question, probably à in this case…?

Please read the tutorial about diacritics.

If you keep installing the font in the system for testing in TextEdit, make sure you use a different family name every time. Or, if you clean the caches, you must restart the Mac.

Thanks for the response.

So I guess the problem is that the character is not linked with Unicode value. I followed the tutorial and it worked for the Aacute and Eacute (the character such as acute appears inside the yellow box before typing the A or E generating “Á” and “É” for example. I thought that the same process would work for the tilde, but it doesn’t. I tested going into preferences in photoshop/illustrator and unchecking in the Type section the “Enable Missing Glyph Protection”, this worked just fine for creating “Ô. But this shouldn´t be necessary for a the font buyer for example.

So my problem is that the correct method for Acute and Eacute is not working with the Tilde + A. Am my still missing something from the tutorial? I am kinda lost.

Thanks again for your help and patience.

Edit: I don´t think that this have anything to do with the problem, I am using a keyboard for brazilian portuguese (ABNT2).

Can you please send the font to support (at) (this website without www), I will have a look.

Usually, Unicode values are set automatically based on the glyph name, unless you enabled Custom Naming in File > Font Info > Other Settings. Have you made sure there is no typo in your glyph names?

I’m having a similar issue with lenited consonants. I’m exporting to the Adobe fonts folder. The font works fine until I type a lenited consonant (alt-w). It appears, but in Myriad. I can select it and change it back to my font which then works fine. As far as I can tell, the glyphs are named correctly (bdotaccent, cdotaccent etc.) and the fact that They work when I select and change them suggest that the naming is correct.

I’m using the Irish extended keyboard. Custom naming is not enabled.

Am I missing something?

Do you have a glyph ‘dotaccentcomb’ in your font?

Thanks for the quick response Georg. Yes, I have dotaccentcomb. I’ve based it on the positioning of the lowercase dotaccents rather than the uppercase, which sit above the ascender line.

I´ve sent you the glyph file and the OTF.

Weird I had the Custom Naming in file checked, but I tested with a total new glyph file and had the same problem. (this time with unchecked the Custom naming).


PS: I know that I used the Ascender and Descender totally wrong for now but I am going to fix it later, that is scalling it down.

As for me I don´t have the dotaccentcomb.

Update: I had been doing my testing in Illustrator, using the Application Support > Adobe > Fonts. With this approach the font replacement problem arises.

I tried testing in InDesign using the app specific Fonts folder. The font didn’t appear initially, but using Type > Find Font activated it. The accents appear normally here, with no font replacement.
Perhaps the app specific fonts folder will work for you too, Komplicado.

Can I assume this is a issue with Illustrator rather than an an error I’ve made along the way?
Thanks again for the excellent support!

What about photoshop? I tested in Indesign and it worked. Although it shows the “no glyph” character and then I can get the “Ô as intended.

It’s not appearing for me at all in Photoshop. I’ve tried both approaches — Application Support > Adobe > Fonts — and Photoshop > Fonts.

I usually have more luck with /Library/Application Support/Adobe/Fonts/ (the library on Macintosh HD). You need to make sure that your user has write permissions in that folder. If the Fonts folder is not there, just make one and restart Indesign (Photoshop).

I’ve tried a few variations.

Using — Library > Application Support > Adobe > Fonts — works in Illustrator but not in InDesign or Photoshop.

Indesign > Fonts — works in InDesign.
Photoshop > Fonts — font not listed.

It’s getting late. I’ll try the above on another computer tomorrow, just to make sure it’s not just a bug on my system.

OK, I got it. For the tilde and the circumflex, there are special characters called asciicircum and asciitilde. And macOS is trying to display those when you type your diacritics. If they are missing, apps like TextEdit will default to a fallback font.

Add those two glyphs to your font, re-export, and you’re fine.

I will update the tutorial accordingly.

1 Like

Thank you! I will wait for the update and check it out! =)

You mean the tutorial update? Done. I added a Hint towards the end.

1 Like

It works!!!

Thanks so much!!! =)