Double nodes after exporting

Here’s a Glyphs file with the lowercase o.
I’ve discovered something: if I disable ‘remove overlap’, the double anchor point appears on a different node than when I enable ‘remove overlap’. Odd!

New Font.glyphs (11.0 KB)

Thanks mekkablue. Yes, I would prefer not to have a grid, like spacing 0 / subdevision 0. Because of the curves that are slightly different (but visibly different) when the points are exactly on a grid.

I tried spacing 1 / subdevision 10 or 100, but no luck. The double anchor points still appear.

There are many places where rounding errors can occur. So small issues like that can happen.

If I set the grid to 1/10, the changed to the outline where minimal and I didn’t see the problem any more.

Hi Georg, thank you!
Grid 1/10 helps a little, but I still get some ‘broken lines’ due to double anchors next to each other.
I noticed that the affected anchor is the first node of a shape. When I make another anchor the first node, this node will be the affected one after exporting the font. Even when the coordinates of the node are changed to round numbers.

This is a detail when I open the exported OTF again in Glyphs (this gives a better picture of the problem than in Illustrator):
Schermafbeelding 2022-02-24 om 09.48.43

I have to stop posting here, i’m getting too emotional :smile:
This is the last one.

The corner in Glyphsapp:

The same corner in Adobe Illustrator, zoomed in.

When you have a line segment, move the start node to the end of the line.

I tried that, it only affects another anchor point.

Lowercase s in Glyphs:

Zoomed in a lot in Illustrator:

could you send me one example that shows this corner?

Do you mean in a glyphs file?

It looks different now, so weird.

Yes, the glyphs file.

1 Like

What emailadress can I use?

support at this domain (glyphsapp com)

1 Like

I had a look at your file and checked the export code. It seems to be a rounding problem in Illustrator. I checked the postscript spec and those small errors are mentioned there. So you can’t seem to be able to avoid them. And it only shows up when you zoom in all the way.

1 Like

Thanks for the investigation. What a pity that there is no solution for now. I have three short questions:

  • Where can I read about these Illustrator/Postscript specs?
  • Is there anything wrong with opening the final .otf files in Glyphsapp, removing the duplicate nodes and saving them again as .otf?
  • Is there a way to draw shapes like this in GlyphsApp with swatches or something like that? I had the idea to make a whole series of weights from one basic centerline.
    1000x thanks for all the help! on page 51.

The double node is not rally in the file. The outlines are drawn with relative drawing operations and if each one introduces a tiny rounding error, the end of the curve will not hit the beginning. And as Glyphs applies the same math, it suffers from the same problems. I see if I can circumvent this.

That is quite complicated to do but possible: with the help of a lot custom scripts.

Thanks for the explanation, this helps a lot understanding it!

I did some testing in Fontlab this morning, pasting the original Illustrator outlines. Fiddled with the starting points, contour directions (both affect the ‘double anchor points’ and where they emerge) and export settings. I mainly try to avoid changing floating points to integers.

No idea why, but in Fontlab I am now rid of my ‘double anchor points’ problem. This is a screenshot of my export profile:

can you send me the file that you exported from FL?

You can avoid this only with a grid setting of 1/1. I suspect that FontLab rounds the values at export.

@mekkablue Just checked it, in Fontlab I work with a 0/0 grid and when exporting this is automatically rounded to a 1/10 grid (coordinates have one digit after the decimal point), so that the ‘error’ can indeed occasionally occur at some curves. I solved this in Glyphsapp per curve by tweaking the shapes and coordinates and check the exported .otf again.

I have learned a lot from this project. The next font will be a more ‘normal’ font with grid 1/1 for sure :slight_smile:

Thank you so much for your help!

I had a look at the file. They round to a tenth of a unit. The most important thing is to move the starting point so that the last segment is a line.

1 Like