Duplicate definition of lookup 'kern_hebr' Found in: prefix 'Languagesystems', line 4

Hi there!
I’m getting this error when exporting. Do you know what causing the problem?


1 Like

It happens to every font when I update the features :0

What version of Glyphs do you have?

Did you open a .otf? Have a look in Font Info > Features > Prefixes > languagesystems and set it to “Generate Automatic”.

I have 3.0.2 and it set to automatic.

Can you send me the .glyphs file?

It’s happening with all my files actually. When I update the features. Maybe it relates to the version?

Then all of your file have a specific setting. It would help if I could try this.

I have the same issue but with arabic, here is a screenshot:

Sometimes I have another strange behavior; when exporting as OTF, G3 quits expectedly, when exporting as TTF, I get the same message as above.

1 Like

I have the same problem
i have Version 3.0.3 (3059)
Screen Shot 2021-01-30 at 6.56.41 PM

@GeorgSeifert I updated G3 and still getting the same error message! I think it is has something to do with kerning written by G2!

1 Like

G3 separates RTL from LTR kerning. G2 didn’t. So after file format conversion, the ‘old’ kerning is left under LTR. That probably causes the duplicate lookup. Working on a script that fixes this.


I have uploaded the script to the mekkablue repo and fixed the issue in Glyphs.

1 Like

I’m having the same problem and cannot export. How is the script called? I was also unable to get the mekkablue scripts loaded to the G3.

I also tried to delete the “problematic” feature (I don’t need it) but it wouldn’t work too.


And I have the most updated version of G3 (just upgraded today, finally!)

This is fixed in the cutting edge version (3.0.2-3061).

1 Like

I recently upgraded to Glyphs 3. (latest version 3.0.2)
But I have this problem and I can not get the output.

> Duplicate definition of lookup ‘kern_arab’

To test, I deleted all kerning and openType features. But the error was not fixed.

In ss03? What does your ss03 look like?

I guess it has not to do with ss03 because By clearing the ss03 glyphs. This error is attributed to the previous feature!

What version of Glyphs do you have? As mentioned above, this is fixed in the Cutting edge version. Activate it in “Preferences > Update > Show Cutting Edge Versions”.

It all started when I added kerning for Arabic letters. (in Glyphs 3)