Error dialog on startup and when opening Plugin Manager

I get thes error dialog every time I open Glyphs 3 and every time I open the Plugin Manager. This has happened on a few different glyph versions as well as before I updated to Big Sur. It’s not super urgent since it’s not blocking anything, just slightly annoying :slight_smile: )

Any idea what it could be?

"The data couldn’t be read because it isn’t in the correct format."

Can you check this page: Cannot download or update Glyphs? | Glyphs

Thanks, I’ll have a look there. I’d just just point out that I don’t have any other issues except for the pop-up window.

Think I just found the issue.

I tried to add my script repo straight into Alternate Plugin Repo like this, not long after updating to Glyphs 3, hoping that I could let Glyphs fetch my script repo from GitHub. I noticed that it didn’t work like that but didn’t think more about it.

I removed it and the pop-up is gone.

You can add a path to a packages.plist file that has points to repos. have a look at this file for references: glyphs-packages/packages.plist at glyphs3 · schriftgestalt/glyphs-packages · GitHub

I have the same issue here; this pop up always show up when I opened G3.

I have seen and tried the terminal tutorial, but it doesn’t work. So I tried the last way to report it here; this is the code I got from my terminal:

Last login: Tue Jun 8 17:27:16 on ttys000
Iqbals-MacBook-Pro:~ iqbalfirdaus$ ping -o
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=41 time=279.585 ms

--- ping statistics ---
1 packets transmitted, 1 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 279.585/279.585/279.585/0.000 ms
Iqbals-MacBook-Pro:~ iqbalfirdaus$ dig

; <<>> DiG 9.10.6 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34755
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

; IN A


;; Query time: 1 msec
;; WHEN: Tue Jun 08 17:27:48 WIB 2021
;; MSG SIZE rcvd: 55

Iqbals-MacBook-Pro:~ iqbalfirdaus$ curl -I

Thank you.

Fastly, one of the internet’s largest content delivery systems, had some issues today affecting a wide variety of websites and services, including GitHub where many Glyphs plugins are hosted. It should work again.

1 Like

Oh, okay. Thanks for your information, I’ll check again tomorrow then. :raised_hands:

Are you still having issues? Loading plugins from the Plugin Manager works for me again.

1 Like

Nope, it’s perfectly fine now. Thanks :+1:

1 Like