Exporting single stroke as non closed paths

is there any option to export font file (otf) with non closed paths? It seems Glyphs closes single strokes as polylines automatically. I need the option for further use in CAD applications.
Screenshot shows the lines and preview in Glyphs, the result in Illustrator and what I want.
Thanks for help.

There are several threads about this already.
Fonts can’t be not closed. There is nothing I can do. Some CAD apps have some special formats to allow that but nothing from Adobe supports open paths.

I read the threads. I can understand. But it is interesting that lines from character “T“ since they are straight appear as open paths in the .otf file generated by Glyphs. Adding them stroke weight renders them as I wanted. But angled shapes from “w“ are closed therefore I assumed the export closes them to support the Adobe apps as you said. If this could be opted out with a custom parameter or similar it would make my workflow more efficient.

The paths in the T are just as closed as the others. When a path closes, it connects the end to the start. The paths you drew in the T consist of two nodes forming a simple straight line. When the paths are closed, the path gets completed along the same straight line, but in reverse. So, it appears to be a single tracing (from start to end), but the path has been traced twice, once in each direction (start to end to start).

What Mark says. If you can break down all outlines into separate straight segments, you can have the single stroke font (sort of). If you combine it with finer grid (use fractional coordinates), you should be able to hide the joint gap fairly well.

@marksimonson I outlined the type in AI, I can see it now. Thanks.
@tosche I already thought of this solution, but it also lacks the smoothness of the curves.
Just to explain the workflow for CAD. Single line font design in Glyphs, outlined single line artwork (typesetting) in AI and export it as .dxf for CAD app to built .shx font. The most time consuming part is cleaning double lines and unwanted closed joins in AI. I can also copy lines from Glyphs to AI one by one, but is the last thing i would like to do. Maybe there is a script for exporting vector paths only from Glyphs to .ai?

Fontographer has an export to EPS command. It puts all the selected glyphs into a single EPS file, and helpfully places single nodes to mark the left and right sidebearings and the baseline.

FontLab has a similar command, but creates a separate EPS file for each selected glyph. Unlike Fontographer, you just get the glyph paths, no metrics or baseline indications.

Except… In order to get the font into one of these other apps, you need to generate a font, which means the paths will get closed. Hm.

Exactly. Coping with that at the moment, all three aps open. As you suggested, Fontographer could be an option for single line font editing and exporting. Will try and get back with results. Many thanks.

The only problem with Fontrographer is that you won’t be able to preview it the way you can in Glyphs. It will preview the glyphs as if they were closed. You can see them as paths only in the “keyline” mode in the glyph editing window. So you’d be working kind of blind.

Too bad Fontographer can’t open UFO files. Open paths are allowed in UFOs.

Ah! But Fontographer can open FontLab .vfb files!

If you’re okay with using Terminal, you can use Adam Twardoch’s vfb2ufo command line tool (http://blog.fontlab.com/font-utility/vfb2ufo/) to convert from a UFO (exported from Glyphs) to a .vfb file that Fontographer can open. I tried it, and it works. Paths remain open. From there, you can export to EPS and open in Illustrator.

I can use terminal by exact dictation only. Installed, moved files in appropriate folders copied the command in terminal from url above and got reply. What am I doing wrong?

I don’t know, it worked for me. It may be picky about path strings. Maybe try cd’ing into a directory first and/or saving the .vfb in the same directory.

Yeah, seems it doesn’t like “~”. Try making the paths more explicit (e.g., “/Users/Leo-Luftwaffe/Docoments/UFO/Lines.ufo”)

Almost there. Got through vfb2ufo converter in Terminal. FLS5 opens converted .vfb as open lines. Fontographer5 opens same .vfb with closed lines. Any idea?

When I opened the .vfb in Fontographer 5, they stayed open. Don’t know what would account for it not doing the same for you.

In Fontographer 5.2.3. demo (build 4868) they stay open. But export to eps closes them again. I still need some time to work around and hopefully find what could be the problem. Thanks a lot.

That’s a shame. You’re right. I hadn’t actually tested exporting the open-path glyphs as EPS from Fontographer. I assumed that since the open paths were preserved, that it would pass them as-is to the EPS.

It’s starting to seem that, if it’s possible, some sort of script solution directly from Glyphs might be a better way.

I don’t know why I didn’t think of this before, but it’s possible to open the UFO in Robofont and use a script to export to PDF, openable in Illustrator with open paths preserved. (There are several scripts and plugins that enable you to save whatever is in Space Center to a PDF.)