Font installed - but wrong font displays

Hi there. Bit of a novice user here so bear with me…

I’ve developed a font with the Glyphs Mini app to display a form of musical chord notation. I exported as OTF and it is working really well on my Mac. I successfully installed the fonts on a Windows computer and can use them in MS Word with no problem.

However, when I open a document on Windows that I previously made on my Mac, where the font is used it is not opening the document with that font. I can successfully select it and change it… but surely it should open with the correct font?

Is there something I’m doing wrong in the way I’m exporting these fonts and naming them?

Any help would be greatly appreciated!

Word document?

Did you have multiple installs of the font on the Mac? Then it could be a font cache problem. Read this please:

Otherwise, can you send me the .glyphs file please to support (at) (this website without www). I will have a look.

I had the same issue multiple times. When opening a MS Word or a Photoshop documents that were created in Windows environment, my Mac refused to display the text in the font that was used. i had to manually select it. Guessing it’s a cross platform issue. Perhaps Rainer will have a better explanation though…

Testing and fixing this problem was a major test when I was intern at FontShop. I didn’t hear about that for some time so I though that the name table entries are correct. Can you send me the .otf and the .doc?

Any non-ASCII characters in the family name?

I’ve just emptied the font cache but haven’t been able to retest the Word doc on a Windows PC. Will get back to you!

Have popped the Glyphs, OTF, and Word files in here:

It should work if you use “Regular” as a style name. I see if I can improve compatibility in this case.

I’ve now changed the style name to “Regular” and it works!

However - why should this be? Because it’s a font full of symbols I’ve been using letters in the style name field, and then putting a whole word in the glyph for that letter, so that when apps like Word display fonts in a list by actually using the font itself, it doesn’t appear as gibberish.

You also could add the letters needed for “Regular” in the font :wink:

Right but that means all those letters become unavailable to me, which is a total hassle! I really can’t understand what the style naming rules are for getting fonts to pick up automatically in Windows.

I could try and work out how to have apps display the font list without using the fonts themselves, but that is going to be difficult (possibly not even an option) on some systems.

The problem is that Windows/Office can’t really handle style that are not “Regular”, “Italic”, “Bold” or “Bold Italic”.

Are those the only options? If they are, I’ll work around it!



I have same issue here and still cannot solve the problem.
My fonts that I have installed both on Mac and Windows (different computer than mine) can work well on Adobe App.

The Word document that I have set in my fonts did not display well. The fonts has changed to another font. I should change them manually in the box.

Can you help me to solve my issue?

Thank you

Office software will resort to a fallback font when a character is not represented in the font, including space and nbspace. Make sure you have at lease the Windows and Mac encodings listed in the Font View side bar, under Lists.

I am sorry, do you mean the Mac Roman and Windows 1252 in the side bar?

Are you sure you installed the fonts properly? For making them work in Word, it needs to be installed in the system. And read this:

I have read about the font cache problems and I have tried the solution.
It is only Work well in my Mac.

There is no problem if I type or change it manually in Word. But the Word document that I have set in my font refused to display automatically when I opened in Word.

Do you know what is the problem?
Or do you need to check my Glyphs file?