Font order on installation

How can I define the order in which my fonts appear on a menu. I’d like them to go from light to black in the right order whenever I install it. How do I do that? Right now they mix up a little bit.

On another forum Georg said “You add a “glyphOrder” key to the fonts Custom Parameters.” Doesn’t sound to me like an easy process for a whole font, but at least it is technically possible.

The glyphOrder has nothing do do with the font menu.

You probably mean the ordering of the styles? That is controlled by the setting of the dropdowns below the style name. if you sent the weight and width setting correctly, it should sort in ascending order.

Hi Eliason, thanks for the answer but it’s actually the order of styles, as Georg mentioned. It works! Thank you both.

Oops, sorry I didn’t read the question very carefully.

Hi - I’m experiencing this problem too, but changing the weight/width settings doesn’t seem to be helping…

Every time I export, regardless of the settings, the imported order is “Light, Regular, Italic, Light Italic, Bold, Bold Italic”.

I should also add that the Light, Regular and Bold masters are in one file, and Light Italic, Italic and Bold Italic are in another file. I’m exporting from both files, then installing the resultant six fonts at once. The drop-down menus reflect the names… I’ve checked numerous times.

Am I doing something wrong? Thanks…

Perhaps ‘installing’ is the key word here. If you’re installing the font systemwide, caches will be a problem. I recommend uninstalling the fonts, restarting the system and exporting the fonts directly into the InDesign fonts folder.

I thought about caches being a possible reason… I did indeed restart the system, and even tried exporting the font with a brand new name to ensure it wasn’t relying on previously cached data. Still no luck.

Assuming this is for something other than InDesign (i.e., the fonts showing up in correct order in any systemwide app), is there anything else you can suggest? Is there a way to manually change the font files’ order beyond what Georg mentioned?

The order in the Font Menu is completely dependent on the decisions of the person who programmed the application. Which app are you talking about?

In most cases, a good guess is the weight class of the font. You can set it manually with the openTypeOS2WeightClass property. 400 corresponds to a regular weight, higher values are bolder, smaller values are lighter.

For apps that use Apple’s library, I found this here: The members of the family are arranged in the font panel order (narrowest to widest, lightest to boldest, plain to italic).

Did you check your width values?


Thanks for the help so far… maybe this will help:

In the non-italic (Regular) Glyphs file, I have three masters, and three instances with the following values:

Style Name: Light
Weight: Light (300)
Width: Medium (normal) (5)
Interpolation Weight: 300, Width: 5

Style Name: Regular
Weight: Regular (400)
Width: Medium (normal) (5)
Interpolation Weight: 400, Width: 5

Style Name: Bold
Weight: Bold (700)
Width: Medium (normal) (5)
This instance is the Bold of Regular
Interpolation Weight: 700, Width: 5

And the italic Glyphs file contains three masters and three instances with these values:

Style Name: Light Italic
Weight: Light (300)
Width: Medium (normal) (5)
This instance is the Italic of Light
Interpolation Weight: 300, Width: 5

Style Name: Italic
Weight: Regular (400)
Width: Medium (normal) (5)
This instance is the Italic of Regular
Interpolation Weight: 400, Width: 5

Style Name: Bold Italic
Weight: Bold (700)
Width: Medium (normal) (5)
This instance is the Bold and Italic of Regular
Interpolation Weight: 700, Width: 5

When I export and install these as part of the same family, the list is (and has always been, regardless of what I try): Regular, Light, Italic, Light Italic, Bold, Bold Italic.

I guess it’s not too big of a deal in the grand scheme of things, but frustrating that I can’t seem to get it.

Try 301, 401 and 701 for the Italics.
In which app are you looking?
How do you install the font?
For testing purposes, keep changing the family name each time (e.g. append A, B, C etc.) to avoid cache problems.

I tried the 301/401/701 settings, still the same. I have been changing the font names for exactly that reason - definitely good advice to avoid the cache problems.

To answer your question, I install the fonts by exporting the six otf files (generated from two Glyphs files each containing three instances), dragging them all into Font Book, then clicking ‘Install’. Then, upon opening any app (TextEdit, Pages, CS3, even within the Font Book application), they’re always listed in the incorrect order.

I even tried adding false width values (that weren’t accurate, but that I thought might trick it into changing the order) to no avail.

If there’s any other information I can provide, please let me know.

I’d say you discovered a bug in the Apple font menu algorithm. You did everything right, as far as I can tell. Try it on a different machine maybe.

And in the Adobe apps, it works as expected?

Hi, can you send me the .glyph and the .otf files?

Thanks for the feedback… to answer your question, the Adobe apps do indeed show the correct order, it’s just Apple’s apps (including Font Book) that never get it right.

Again, thanks for your efforts.

Georg - I’ve sent the files to you, please let us know if you’re able to solve it!

On first look, everything seems right. This seems to be a MacOS problem.

Georg Seifert
Hmm… if it’s a MacOS problem, then I guess there’s nothing we can do about that.

I do appreciate the time everyone has put into this, and am glad that it wasn’t just a problem on my computer (or with my fonts).

hi everyone,

experiencing exact the same problem. i am trying to export a family of display fonts, not a regular range from light to black but with specific names.
i set the weights (100, 200, … 800) in the order i wanted the fonts to appear in the drop down menu but indesign does not show it correctly but mixed up.

names are like:
Liverpool Basic Clean
Liverpool Bacic Rusty
Liverpool Combined Clean

‘Liverpool’ is the family name, and ‘Basic Clean’ is the style name.

putting the files into font explorer instaed of only the indesign font folder results in a partly correct order.
i have no idea which rules the ordering is following.

i then changed the style name to ‘BasicClean’ (no space) and so on, but that did not change anything.

is there really nothing we can do about that? (mac os problem)
can you help?


You could combine it with the width setting (condensed, extended etc.), works fine in Adobe apps. The fonts will be ordered (1) by width (2) by weightClass.