Glyphs 2 crashes on opening due to persistent corrupt autosaved file

OS X 10.10.4

Glyphs crashed after testing a cap component…(which I clearly messed up since the program crashed) and since then it crashes on open, can’t even get far enough to send a crash report. (Could be trying to reload a previous state?)

I don’t know what version I had before, but I deleted my .app and am using the version supplied at the download link at ‘Buy’. I deleted cache, saved states and preference files (not the main one at ~/Library/Application Support/ though). I even deleted the autosaved .glyphs file that had caused the initial problem.

Very frustrating as I can’d do any work at the moment.

I deleted all associated Glyphs files using AppCleaner and restarted my computer, the first time I re-opened Glyphs App (789), it worked but still re-opened an autosaved version of the corrupt file… I don’t know how it found it, whether it’s in the system cache or something, How do I clear this cache…?

Look at this insane left side bearing…

The autosave is probably in the working directory of the original file and not in the temp directory.

There should be a file with “(Autosave)” in the the name next to your original file. If you still have it, could you send it to me?

I have deleted the directory because I knew it was opening the (Autosave) file, still Glyphs App is retrieving it somehow from a cache.

I delete all the following and it still persists… :fearful:

I even tried to be clever and restore the original folder, and make a duplicate of a healthy file and added the " (Autosaved)" suffix. Still no use…

Edit 1:
There was a preference file here that was pointing to an autosaved file (where? I have no idea…)

~/Library/Autosave Information/

I deleted this and Glyphs worked again… BUT when I tried to restore my previous settings it crashed again.

Edit 2:
I found my mistake, I had the newest (789) .app and instead I used an old (782) version and now it works. I found out it 789 didn’t work due to Georg changing the GlyphData.xml format: Glyphs 2.1.1 (789) Crashes on opening

I am now however terrified of using cap components.

Is it possible to abandon a new version of Glyphs and re-install an older one?

I explained it here: