Glyphs 2 files causing Glyphs 3 to crash (and other issues)

The majority of files I have created in Glyphs 2 are causing Glyphs 3 to crash when I try to open them. I’ve created a test file in Glyphs 2 with a single glyph (a square) and that opens fine. I’m not sure what could be causing the crash. Any ideas?

Following up with some more details:

OS version: El Capitan 10.11.6
Glyphs Version: 3033
No plug ins are installed

I’m also having some more issues:

Creating instances causes a crash
No option to add weight in Axes Coordinates
Unable to double click many input options such as font name metrics etc.
Unable to click and open previous projects on the open window

In order to isolate if it is an issue related to macOS 10.11 or the files, can you send me one of the files?

I suspect that the files may need some clean up in Font Info, and that some issue may arise from an incompatibilities with macOS 10.11. We are looking into the issues.

Can you specify where exactly? In Font Info > Exports? Do you have a wght axis set up in Font Info > Font?

Do you mean you cannot select the value? Does resizing the window, perhaps dragging it very wide, help?

Do they open through File > Open Recent?

I’ve just sent you one of the files there.

I didn’t. Setting this up solved this problem.

Yes I mean I cannot select the value. Resizing the window doesn’t help but if I click once, wait a second or two and click once again it selects.

Yes, they open through File > Open Recent, but not when I try to open them from the pop up window.

Thanks for your help.

Hi there,

Just purchased G3 and I’m having the same issue as archieheaslip.

I can’t open G2 files in G3. It crashes every time.

I have the same configuration:
OS version: El Capitan 10.11.6
Glyphs Version: 3033
No plug ins are installed

And did the same test with a new created file on G2 with a single glyph.

I’m stuck here.
Any help would be appreciated.

Many thanks.

Can you send me that .glyphs file?

Can you open a new file in Glyphs 3 or are there any files that do work?

I don’t believe that the files are the problem but most likely a plugin is causing the crash. Can you start the app with Option and Shift key pressed?

OK. I’ve tried with several files and the problem remains. I can open Glyphs but opening existing files crashes the app.


PS: As a new user, I could not answer you directly (max 3 messages).

Can you open a new file and draw something in it?