Glyphs 3 Crash in Big Sur

Glyphs 3 hasn’t been opening for me, quitting unexpectedly right as I click to launch the app. It was working before, but not entirely sure what went wrong.

I’ve tried the troubleshooting recommendations in the Crashes Tutorial by Rainer Erich Scheichelbauer. Throughout the process:

  • I was prompted with a Problem Report, however there was no second prompt for me to send a crash report to Glyphs.

  • I have the app updated to the latest Cutting Edge Version.

  • I tried disabling the plug-ins, deleting the prefs, as well as autosaves (doing each separately) but still no luck.

  • I am running on Big Sur 11.1 on a MacBook Pro (2017) i5.

Currently running on a trial version of the app. Recently decided to upgrade from Glyphs Mini 2 and am excited to try out all the features in Glyphs 3, but before I purchase the license, I would like to make sure I won’t have the same issues.

Any help would be much appreciated. Thanks!

Same here, and I did buy a license :slight_smile:
I was teaching and wanted to show something in Glyphs, but all I get is: image
I even downloaded and installed a fresh copy on this up-to-date Mac, but Glyphs seems knocked out.

1 Like

It might be a Big Sur issue. I have a new Mac but refrained from upgrading to Big Sur fearing just this. I am running fine on Catalina 10.15.7

1 Like

I also prefer OS9 but consider it good practice to keep some computers OS’s up to date. On my Laptop, which runs BigSur 11.0.1, Glyphs 3 runs fine. But on this iMac Pro with BigSur 11.1 it keeps on crashing immediately.
I updated Glyphs 3 on the laptop and copied the app to the iMac to no avail.
Is there a problem with 11.1?
Glyphs 2.6.5 runs fine on both BigSur versions.

That is most likely because of an plugin that is not updated, yet. I’m fixing them as time permits. Can you start with Cmd+Shift Option+Shift keys pressed (that temporarily disables the plugins).

Hi I am having a similar crashing problem tonight. Glyphs 3 was working fine on BigSur 11.1 until I installed plugins and modules, and now everytime I go to start Glyphs 3 it won’t open. I even tried reinstalling Glyphs 3. and restarting computer. Cmd+Shift keys upon start does not prevent the crash.

Sorry, I meant Option+Shift.

And can you show a bit more of the crash report? Maybe I can see what plugin it is?

Yes Option-Shift helped, thanks.
I only had speed punk installed, without it, no problem starting.

I installed Speedpunk for Glyphs 2, it then becomes similarly unresponsive.

Installing Speed Punk from the plugin manager in Glyphs 3 works for me on macOS Big Sur 11.1

installing Speedpunk worked here as well, but when trying to open a font…image
(no other extensions installed)

Hm, I have selected Python 3.8.2. Other than that I have no idea what part of the setup might differ.

I switched from Python 2.7.4 to 3.8.7, but it still freezes with Speedpunk installed.

If I switch to Python 3.8.7, Speed Punk does not work.

Try installing the Python version as provided by Glyphs from the Plugin Manager → “Modules” → “Python” and in Preferences → “Addons” choose the one with “(Glyphs)” after the version number (like in my screenshot above).

That special Python version works, thanks! And I thought I would have less stress with Python versions and modules on Mac than on my PC :slight_smile:
In the meantime I sent a crash report and Georg is solving problems.
I love Speedpunk on wild glyphs

JesusLovesYourPunk :wink:

1 Like

Ahhh - Option+Shift works. :raised_hands: I did not install Speed Punk. Now that I’m back in I’m going to use the Plugin Manager and uninstall all the plugins from yesterday. Thank you so much for looking into this.

Edit: Uninstalling plugins works! no more crash

Full Crash Report uploaded as PDF:

Glitterturd-CrashReport-BigSur.pdf (98.7 KB)

I was having this problem in Catalina over the weekend. I just upgraded to Big Sur, in part to see if that would fix the problem, but it didn’t. Using Option+Shift doesn’t help get the program running, in my case. I did update my system Python at some point before the crashes started. Wondering if that’s the issue for me. I’ll do some tweaking, but if you have any ideas, I’d love to hear them. Thanks,

crash.pdf (157.6 KB)

  1. Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.
  2. The crash report suggests that a plug-in crashed the app. I would try restarting the app with Opt+Shift again (and make sure you do not accidentally hold Ctrl or Cmd instead).

Just the text would be a better idea (and save some bandwidth), no need to convert it to a PDF.