How to PUA encode an existing font?

Can you send me the .glyphs file? To support (at) (this website without www), please. I will have a look.

And can you send a screeshot of the settings dialog from Word? And what version of Word do you have?

Hi, just sent you the file.

Hi, here is a screenshot.
Also, I just realized that a few of the letters are also cropped from the top on MS. why could that be?

I’m using the 2016 version of MS Word. I got it today itself just to check because the user said he couldn’t use the ligatures on Word. I’m using it on a Mac.

The glyphs are cropped because your vertical metrics are wrong. https://glyphsapp.com/tutorials/vertical-metrics

  1. File > Font Info > Font > Custom Parameters: lots of conversion artefacts, you can delete all of the parameters there.
  2. File > Font Info > Font > Features: Delete all features, then click Update and Compile.
  3. All your glyphs are 250 units above the baseline. If this is not intentional, select all glyphs and try Filter > Transform > Transform with Translate Y: -250.

Then, export as TTF, autohinting off, overlap removal not necessary (no overlaps in the font), install, and it works as expected, provided the respective settings are made in Word:

I think the problem was that no default languagesystem was set. For word, all GPOS feature rules need to be registered in a languagesystem.

Hi,

I did all of this and I also tried changing the font name and restarting my computer as suggested by @GeorgSeifert. Still not working for me.

Also, I am working on another font that has ligatures and I checked but its not working in MS Word either. Just not sure what am I doing wrong here.
The ligatures seem to be working fine everywhere but MS Word.

I had someone test it on a Windows computer as well as its not working for them either. Even the character map doesn’t show the ligatures.

I’ve also tried clearing the cache as mentioned in the article on this website.

Did you select the text before applying features?

Hey,

Not sure what you mean. Do you mean if I selected the text in Word? Yes, I did.

Also, if you mean if I selected the Glyphs before applying the changes, then I did that too, even though I think that wasn’t really needed. But I tried it when nothing worked.

Can you send me the font you exported?

The font I was able to export (as described above) worked without a hitch in Word.

Yes, I’ll do that.
I asked for the font @GeorgSeifert exported as well and I just checked it. It doesn’t work either.
I’ll send you the one I exported on support.

The font you sent me works, the ligatures th and tt form as expected. There must be something wrong in the way the font is applied and which settings are set in Word. The font itself is OK.

Perhaps try experimenting with the settings, selections, etc. Make sure the font is really replaced and you are not accessing an outdated version. Do you know how to clear font caches in Windows?

Hey,

I’m using mac and I’ve cleared all caches and applied the settings too. Played around with it as well. Can’t figure out what could be the issue. The client who is using the font also can’t get it right. He’s on windows. He has tried using other fonts and they seem to be working fine. The issue crops up only with my font.

I also created a new font and installed it for the first time so there can’t be any cache’s. But it too has the same issue. The ligatures don’t work and the option to use them is also greyed out in the ‘text effects’ drop down.

I believe this is a languagesystem issue. I just tested two versions of a font of mine. The first one had

languagesystem DFLT dflt;

and the second one had

languagesystem DFLT dflt; languagesystem latn dflt;

As you can see from the screenshot below, Word needs the latn dflt bit for the OpenType features to work. All text has ligatures enabled.

Glyphs used to add both lines automatically, but now only adds the first one. This problem has been around for a while:
https://forum.glyphsapp.com/t/opentype-features-ms-word/

@GeorgSeifert and @mekkablue, is there a reason Glyphs stopped adding the latn dflt line? Is it possible to revert the previous behavior?

2 Likes

Hey, Thanks a lot for confirming this.
I was reading another thread and I thought this could be an issue. I had tried adding languagesystem latn dflt; but I couldn’t. It kept going back to DFLT as soon as it updated.

Not sure how to add it to check the same.

Uncheck the automatic.

Man! I can never thank you enough! It worked!!! Thank you SOOO much!

Also, @mekkablue like @harbortype asked, is there no way to get back to having the line added automatically?

2 Likes

It adds automatically once you have one locl feature in Latin.

  1. e.g., add the glyphs iacute and jacute
  2. automate all features
  3. update feature code