Interpolation Problems – Dekink


#1

I’ve got a problem with the interpolation in the version 1218. I’ve got a six masters setup. Instances are made in 5 widths and 10 weights. For the most part all instances look good and I’ve started adding additional masters for individual glyphs (the Brace Trick). The problem appears when i tried to fix the appearance of the number 2.

Here’s how it looks, I’ve marked the problems:

When I add a master to fix the Condensed Thin instance, the problem on the Condensed Regular instance remains:

Then I add another individual master, and this happens:

If I turn off the CondThin individual master things look better, but the problem with the CondThin instance returns:

Any ideas what’s going on? I’ve tried the 1075 version and it doesn’t make this problem, but I really wouldn’t want to go back to old versions. I’ve checked all 6 masters and there are no kinks anywhere and the paths are compatible.


#2

Adding new masters will not fix this. This is a kink. They usually appear where two curves connect diagonally. but also when a diagonal line and a curve connect. The proportions of the diagonal line and the tangent handle need to be the same in all masters.


#3

I’m not sure I understand this. Do you mean (for example) if in one master the line is 10 points long and the tangent handle is 6 points long, in another master if the line is 20 points long, the tangent should be 12?


#4

Yes. Or keep the angle in sync.


#5

See the MM tutorial about ‘keeping your outline compatible.’


#6

OK, although I’ve been using the dekink script many times I obviously did not understand fully how it works. Thank you @GeorgSeifert and @mekkablue, now I get it. And the MM tutorial explains it perfectly. Although I read it more than once in the past couple of years, this bit of information about keeping things proportional somehow eluded me.


#7

If it is static fonts you are exporting, you could add the RMX Dekink Only function as custom parameter. Very short handles and segments will always be problematic though.


#8

I know that, but I prefer to have full control of the final shape. Turning on that custom parameter kinda feels like “hey I can’t solve this problem but let’s click the auto button and hope for the best”. :grin:


#9

The outcome of the parameter is predictable and verifiable. You can double check the resulting shape in the preview area, so you do not give up control over your shape. I would give it a try.