Issue with instance preview appearing inconsistent in "Show All Instances" view

I wanted to report an issue I’m experiencing with instance preview.

When previewing my font’s master or individual instances one at a time, the preview is correct. However, when using the “Show All Instances” view, the preview for my Thin instance seem to be displayed bigger than the other instances.

I’ve attached two screenshots to illustrate the issue:

[Screenshot 1] This shows the “Show All Instances” view, where the Thin instance appears significantly bigger than the other instances.

[Screenshot 2] Metrics are configured with the same value for all instances.

I’m not sure if this is an actual bug or perhaps some setting I have misconfigured on my end.

Any insight into what might be causing this discrepancy would be greatly appreciated.

Let me know if you need any other details from me to investigate further. Thanks in advance for your help!

From your screenshot, I would assume you are talking about your masters. Do you have any custom parameters set, such as winAscent, typoAscender or hheahAscender?
There is also a custom parameter called something with preview height. Do you have anything set?

Edit: it looks like your “larger” instances are extrapolations, meaning they are not actually situated within your design space. Check the axis values again and make sure you are picking values within the range defined by your masters.

No, I have not configured any custom settings or parameters beyond the basic options. These are just the default settings in Glyphs.

Thank you for your assistance. :+1:

I will try creating a new font file from scratch using the same basic settings to determine if I can reproduce this issue.

What have you set in Font Info > Other > Font Type?

Did you see my note regarding the extrapolated instances? I am very sure that this is the issue.

Reconfigure the instance axis values to sit within your designed axis range.

My settings

I only have one axis defined, which is the Weight axis. The range for this axis is set to match the standard 100 to 900 values corresponding to the font weight.

Would it be better practice to use a value range from 0 to 100 instead, with like 10, 20, etc. for defining the weight instances?

I’m wondering if using the 100-900 range could potentially be causing the inconsistent metrics display I’m seeing when viewing all instances together.

Please let me know if adjusting to a 0-100 range may help resolve this issue. I’m happy to try that approach if recommended.

The range doesn’t matter. What matters is that the range defined by the masters corresponds to the range covered by the instances. Keep your instances inside the range defined by the masters. In your screenshot, it very clearly looks like you have two extrapolated instances (= outside of the range defined by the masters) as your first two instances.

Can you list the axis values you used in your masters, as well as the ones used in your instances?

I was able to reproduce the Preview issue.

It seems the problem occurs when manually changing the Weight (axes) settings directly in the masters and instances. If I remove all the existing instances and recreate them from scratch, the preview displays correctly and consistently across all instances.

Manually editing the Weight axis values in the masters/instances after initial setup appears to cause issue in preview when viewing in the “Show All Instances” mode.

Can you set the font type to “Default”? The variable setting doesn’t support extrapolation.

1 Like

Masters Weight:

  • Thin = 100
  • Regular = 400
  • Black = 900

Instances :

  • Thin = 100
  • Light = 300
  • Regular = 400
  • Bold = 700
  • Black = 900

Fix the issue.
Thank you

If I would like to have a variable font what do I need to do?
Where I can find more information about it?

I have found this.

In order to have extrapolated axis locations in your variable font, you will need to add masters at those locations. Extrapolation is simply not possible in a variable font (at least not before avar2).

1 Like

Make sens. Thank you. @GeorgSeifert :muscle:

Merci @SCarewe :wink: