MakeOTF error "lookup name "lookup_0"

Hi, I have a typeface family that gives an error message, when exporting. It said this
And in the script folder it writes: makeotfGlyphs (FATAL) lookup name “lookup_0” already defined (features.fea 97)
I have Glyphs version 2.4.4
What to do?
Best Jan

I am having this same error. Is something up with Glyphs?


  • cleaning font cache
  • re-naming file to be exported

That should be fixed in the latest cutting edge version. It is feature code imported from .otf files. You need to reimport the file manually clean up the feature code.

1 Like

Thank you Georg

George - not sure I totally follow the solve. Is there a recommended tutorial I can do to learn more about “Manually cleaning up the feature code” that you might recommend?

This might help:

1 Like

Very helpful - I had skimmed that article earlier when I didn’t fully understand the problem but think I’ve got it under control now. Thank you very much for the help!

Hello y’all. I’m having the same error as well.
I did some renaming in a font I made years ago in Fontlab.

This is the error I got when trying to export an OTF:
Error: “lookup name “lookup_0” l_ready defined” in Feature calt in line: 2
I followed the instructions above from the link by Georg: and got this line:
makeotfGlyphs [FATAL] lookup name “lookup_0” already defined [features.fea 50]

How did Jan & Kuyle manage to overcome this error? Please let me know!

Could you send the the .otf file you imported? That might help me to prevent that problem altogether.

Yes, can I send it to you directly?
(and how do I do that? - without the file being displayed publicly)

Send the .glyphs file please to support (at) (this website without www).

Thanks MekkaBlue & Georg for answering.
I have just send you an email.

For other users, Georg replied to my email:
In what version of Glyphs did you open the .otf? I opened it in the latest cutting edge version and the OpenType features do compile without an error. But for complex substitutions like this, it is better to keep the original feature code by exporting the file from Fontlab as a .glyphs file or .ufo. (

First I opened the file in 2.4.4, but opening it in Cutting Edge version Version 2.5b (1099) did the trick.

Hope this will help other folks who ran across this problem.

Hello everyone,
I have the same, or a similar problem. I have created an OTF font in Glyphs (2.4.4 version) and for me it works fine. But when I opened the exported font, so as an OTF font in Glyphs (it’s a long story why did I do that) and when I tried to export it from Glyphs, the following message appeared:

Error: “lookup name “lookup_0” already defined” in Feature calt in line: 1

(This font has some lines of a contextual alternate feature. I have the feeling maybe that creates the problem.)

I have read all the post and comments here. I went on the link what Georg posted way before.
Reading through that text there is a link points to the Error Handling chapter in the Handbook, but that page does not show any text besides the headline. I wonder if the solution would be there. If not, any suggestions would be a great help.

Importing an existing OpenType font is quite difficult to get 100% the same feature code. So there is nothing wrong with the font, just the import fails. Why do you like to open the .otf. Just stick to the original data.

1 Like

You can download the handbook from the Get Started Page on this website. See the links at the top of this page.

1 Like

Thank you for your answer. Sorry for my very late reaction.
The reason why I opened and tried to export my existing OTF is because I was testing it, and though it worked fine on my computer, there was a little problem on my friend’s computer: he couldn’t place that OTF into his Indesign font folder. It just didn’t work. So I thought there might be a problem with the OTF file. With any font management program it worked though. So I just wanted to be sure whether the OTF has the problem, or it’s in his machine or somewhere else.

But opening a font in any font editor is not a good idea when you are trying to solve a problem like this.

1 Like