Manually installing Vanilla, 2020

In his post Manually installing vanilla module, Georg gave several steps to install the Vanilla module. However, that isn’t working for me. Is the module only available in Python 3, or something similar?

Thank you for any insight on this!


I am trying to use the word-o-mat plugin, but it gives me the following error when I try to run it:

This plugin needs the vanilla module to installed for python 2.7

Attempted solution

I have attempted Georg’s solution, downloading the Vanilla zip, then moving the vanilla folder from vanilla > Library into my Glyphs script folder. However, when I try the following in the Macro Window:

import vanilla
print vanilla

…I get the following traceback:

Traceback (most recent call last):
  File "<macro>", line 1, in <module>
ImportError: No module named vanilla


  • macOs Catalina, 10.15.5
  • Glyphs Version 2.6.5 (1341)

Have you tried installing the modules from Preferences > Addons?

When you download vanilla, the folder contains a folder “Lib” and that contains another “vanilla” folder. This one needs to go into the script folder.

I encountered this as well after installing some new plugins.
Tried to do as Georg said — but it gives me an error message saying:
Screenshot 2021-04-01 at 1.26.16 PM

Which exact version of Glyphs 2?

Consider updating to the latest cutting edge version if you don’t have it already.

Hey Rainer,

I just reinstalled Glyphs 2 and loaded everything up again. So far so good!

1 Like