Pinch to zoom feels choppy and too fast (3.1.2)

Compared to something like Figma, Glyphs 3.1.2 feels really choppy and over accelerated using pinch to zoom on a Mac track pad. Any tips on getting this smoother?

You are right. I rarely use pinch zoom (try it in Adobe apps and you become crazy). I tweaked it a bit to feel better.

And do you have any plugins installed? And how much text do you have in the edit view?

Thanks for the feedback Georg! Still looking choppy with and without plugins. I’m coming from Figma which is buttery smooth on desktop app and in browser. Would love a feature to zoom in on selected point(s) so the zoom bullseyes and centers straight to that area. So much zooming in and out with type design, I find this feature super critical.

You can also use Cmd +/− to zoom, and Cmd-zero to go back to fit the window.

But generally I stay zoomed in for editing in Edit view, but will have the preview area (click on the eye symbol in the bottom left to open it) at a small scale to see how the design works in a realistic text size.

Thanks mekkablue,

I love that workflow with the side by side. I’m still craving a smoother pinch to zoom experience. Where the distance of the zoom changes relative to the pinch speed (a higher resolution, less jumpy frame rate at slower zooms). I never use key commands for zooming while using a trackpad. (sometimes to return centered to full size)

I made you a video comparison between Glyph and Figma. With Glyph at $300 and Figma being free, I think there is a sound argument for requesting a higher fidelity trackpad zoom. I will never stop asking you about this, haha!


might be somewhat related:

Updated today to 3.2 (3178) and I feel like the scroll to zoom (using mouse) behaviour is now ruined for me. Went to check change log and found this in 3178:

" * Improve zooming with trackpad pinching "

Could this be related? I use mouse solely to zoom and now it takes like 4-5 scrollwheel turns to go from 10pt to 800pt+, so waaay too sensitive. Can I adjust the sensitivity somehow to go back to how it used to be?

Thank you.

I indeed changed the sensitive a bit. It might be using a bit acceleration, now (so can use try to scroll a bit slower). It seems that I need to calibrate the scrolling speed a bit for different mice.

Oh no! I just noticed that in version 3.2 (3178), the mouse wheel zoom got MUCH too fast! Compared to 3.1.2, where is is just right. I am using a plain wired Logitech mouse and option+scroll wheel.

Ah, so it’s not just me. I thought something felt off. An option to set the mouse scroll sensitivity would be really useful!

I rather get right. I’ll see if I can fix it. Otherwise I revert to the previous code.

What about the speed of the trackpad (pinch zoom and option+two finger scroll or whatever one uses to zoom with the trackpad)?

I absolutely love this zoom update as it performs on a trackpad, thank you Georg! This is exactly what I was hoping for. I would be heartbroken to revert to the previous version. Hopefully there is a solution to solve for both mouse and trackpad.

Just noticed that in Glyphs 3.2 (3182), this problem is still not fixed. Zooming with the mouse wheel is much too fast. This keeps me from using Glyphs 3.2, so I am stuck with Glyphs 3.1.

I made it a bit slower.

The zoom with mouse wheel is still much too fast (version 3184). Feels very uncomfortable. Maybe we need a user setting for this?

Is it slower than 3182?

I guess so but still too fast.

What brand/model of mouse do you use. What is the speed setting in system preferences?

On my Mac Mini with a Magic Mouse, I personally find the zoom okay, maybe I just got used to it because I use it constantly. My tracking speed is set to 6 on the scale from 0–9.

While you’re on it, is there any chance of looking into making the scrolling smoother? It is indeed very choppy. Or is this a limitation of how the zoom is implemented?

I reduced the choppiness quiet a bit a few weeks ago (in the 3.2 version). But it depends on the speed of the redrawing of the edit view. And that can be limited by some (python) plugins. Can you try running Glyphs without plugins (Option+Shift on app start) and see if it makes a difference?
And if you have a lot text in the edit view, can slow things down, too.

So if you have no plugins and one (empty) glyphs in the edit view, it should be quite smooth. If that still feels slow/choppy, I would need to have a look at it.

Was trying to switch from 3.1.2 (3151) → 3.2 (3207) and the first thing I noticed was how different the zoom speed it using the trackpad. It is significantly slower in 3.2.

I realize there are different preferences for speed and tools for people so is there any way to manually adjust the zoom speed on the user side?