Plugin Manager not working version 922

when I try to install the Broad Nibber for example, there is no response–no install. In the console:
/239/2016 10:26:38.136 AM Glyphs[26954]: Git fetch output: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

What happens if you type “git” + return into the terminal?

The Plugin Manager requires git. It is usually installed automatically. If not, download it from this page: and install it manually.

AirdeNaieDumont:~ Nathalie$ git
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
AirdeNaieDumont:~ Nathalie$


  • it used to work well before the upgrade to 922
  • i will upgrade later today to the new version

I’ve been hitting the same problem with the plugin manager (I’ve verified git 2.9.0 is also installed and running fine on my mac)

Specifically, clicking “Install” on a plugin makes the button flicker temporarily, but nothing happens:

System Info:

Cheers :+1:

EDIT: The flickering is not captured in that GIF sadly…

Got the same on OSX 10.11.6 (15G31)
Glyphs 2.4b (923)

I thought the PM repository got some issue perhaps?

Can you check the if you see anything there?

I have run Console while performing the Install action - it does generate a heap of information in the log though. If you can let me know how to export that info, I’m happy to share it with you.

One is coming up multiple times:

Git fetch output: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

There are two options. If you have the, use it to install the command line git tools from Preferences > Advanced.
Or follow this video:
most importantly the last 2 min.

I first reported this issue regarding the Plugin “Stem Thickness” to the author on August 8 when Build 913 was current. He responded recently: “I’m working on this issue. In following weeks it should be ok.”

His is the only Plugin I’ve ever encountered the problem with so I’m not sure where the install fault might lie.

I fixed the Stem Thickness plugin. It was not set up correctly in the packages repo.

Sure but can you walk me through it?

It downloaded and installed git and I am now using version 923 but the Plugin Manager is still not working.

Do you still get the same error message in the console?
If so, try installing gut from the github app. I think they set it up correctly.

I get this message in the console:
/279/2016 2:58:07.670 PM Glyphs[18271]: Git fetch output: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

… will try to install git from Github.

For people that have installed git manually, and it still doesn’t work, run this two command in the terminal:

sudo mv /usr/bin/git /usr/bin/git.xcode
sudo ln -s /usr/local/git/bin/git /usr/bin/git

It will ask you for your user password. And it does not show something when you type, don’t worry it will still work.

mv: rename /usr/bin/git to /usr/bin/git.xcode: Operation not permitted

I entered the pw of course :slight_smile: tried several times. I don’t have xcode on this machine. Could that be a reason?

I also (re)installed the command line tools from the

Now, after restarting the Github app and trying to reinstall the CLT again, I get this Error:

Authorization Failed
You may not have permission to install files as an administrator.