Python Runtime not installing?

Hi – I wanted to install the script for identifying Kerning Groups, but I seem to be stuck in a loop of the Python Runtime installing (or not installing). I’m assuming it needs it to run the Kern script, but each time I launch Glyphs it asks me to install, and that it’ll run on the next launch – but I keep getting the same message? The same happens from trying to install via the Scripts menu.

Is there anything I can do to resolve this?


Glyphs 3.0.1 / MacOS 11.0.1

Screenshot 2021-01-18 at 09.30.47|410x218

Weirdly, since this started happening, I don’t seem to be able to paste anything from Illustrator either?

Thought I’d try a reinstall to clear all the settings and hopefully resolve the issues, but each time a reinstall, my setting seem to be retained. I’m using AppZapper to find and remove all files, so there must be a Pref file it’s not finding?!

Do you have an Apple Silicon mac?

Hi - yes, I do, but I think it was all fine when I first got it up and running. The issues seem to have arisen since I tried installing the Python Runtime?

The Python Module is not yet compatible with M1 macs. You need to install python manually. I’ll add a different warning.

Thanks - is that relatively straight forward?

1 Like

Thanks – I’ll have to put some time aside to take that all in!

Will this also fix the issue of not being able to paste from Illustrator?

I followed those instructions, and installed the Python 3x, and the following Terminal command instructions.

I’m still unable to paste from Illustrator – I just get the spinning beachball of death, and then nothing happens.

Also had this after a restart, after I’d installed the Kern Group Set plug in?

Screenshot 2021-01-19 at 11.56.39

This dialog is not Python-related and doesn’t go away as of now (it’s M1- related though), and not fixable on the user’s side. My question to Georg is, is it the app or plugins that needs updating?

The Illustrator paste issue is probably bigger for me now – most of my type I’m working on at the moment was originated in Illustrator!

I was facing the same issue, no error was given of any sort. I agree with @GeorgSeifert that it is a Mac OS issue.

Installing Python manually is possible. Here is a link to the Python website for the Mac OS latest releases:

Python installations through the plug-in manager should work now also on M1 Macs. Make sure you have version 3.0.3 (3091).

Hello! Python Runtime wasn’t installing for me, so I installed the latest version of Python manually.
However, when I install for example SpeedPunk, I get this message after restarting the app :

Then, I run this command (“pip3 install pyobjc”) in the terminal and it doesn’t work. I even tried “xcode-select --install” before writing the other, and I receive an error message in the terminal. I can’t use SpeedPunk in Glyphs 3 :confused:

The one from the Plugin Manager? What error message did you get?

Which Python version is selected in GlyphsPreferences…Addons?


The Python version selected is 3.9.1.

This is the error message I get when I open Glyphs 3:

Then, I desinstall the plugin, and I reinstall it — I get this message, which seems to be a good sign:
Capture d’écran, le 2021-07-15 à 18.57.38

However, once I restart Glyphs (to get the plugin started), I receive this message:

So that pretty much sums up the issue I have

Does it say “(Glyphs)” after the version number?