Remove style name?

Hello guys!
Using GlyphsMini for a couple of months now and it so much fun!
I just finished my font building, my spacing, my kerning and I’m ready to export.
Everything goes smooth, the font works etc.
Only thing I noticed is that the file keeps “Regular” in the name.
I imported it in FontExplorer X Pro to do some tests and the file is being read as
Name: FontName Regular Format: OpenType Style: Regular
Used in Illustrator and it looks like the name is still “FontName Regular”

Now, first thing I did is go back to GlyphsMini, go to “Font Info” and see I have a name box (I suppose) with the name of the font, and “Regular” in another box which, if I delete it, a greyed-out “Style” appears.
I tried to export with no word in it, but as soon as I click export, “Regular” comes back.
I tried using a space glyph " " as a workaround but an error pop-up comes out.

Looks like I’m stuck having “Regular” in the name of the font which I’d like to have not, also because this is a single style font and doesn’t need any style specification.

Hope you could help me with this, thanks so much!

Operating systems and applications need to know a style name of a font. If it is absent they assume Regular.

Glyphs by default appends the “Regular” to the full name to make work better if you have more styles in the family.

I get it, but is there a way to remove it from the name so it stays only on the style dropdown-menu? (like Impact does)
I made some tests, it looks like the only way to have it removed is to have different weights (which I don’t have) and also looks very automatic. I can call it whatever I want instead of “Regular” but it’s impossible to avoid the repetition.
Just wondering how Impact has no descriptor in the name. Also noticed how many amateur fonts like the ones on DaFont behave the same.

What happens if you install a second font with the same family name but a different style name?

That’s what I did, exporting it a 2nd time with a different name in the “style” section called “whatever?”.
As long as I have both versions installed (“Regular” and “Whatever?”) the font name loses the style descriptor, cool.
But when I deactivate/uninstall one of the 2 versions, the descriptor comes back repeated in the character name.
My problem is I only will have 1 weight and “Regular” is not quite the right descriptor.
I could call it “-” or “A” as a workaround but it kinda bothers me.

Note: On Photoshop there is no repetition and so everything looks fine : New Font / Regular (Instead of New Font Regular/Regular)…

That would be a bug report for Adobe then. Because that’s how they make the AI font menu. :man_shrugging:

1 Like

Perhaps a few similar threads? It seems to be primarily AI that does it (Indesign handles it ok).

1 Like

Thanks so much for your patience, looks like it’s Adobe problem then! I’ll report it, if it was of any use.

Still nothing happened? Its no possibe export name i wish for example “filip.otf” maximu i can get “filip-.otf” omg. That’s worst what can be in the app, cant choose my own export name, exist hundert reasons why someone need it. With this scenario ,100% perfect app ,100% useless for me.

Have you tried the “fileName” custom parameter in the instance settings?

No, thanks for reply, where i can find custom parameters?, I looked in the font setting, project sett… , i cant see “instance setting”, or its nick for something? thanks

The instance settings are under the Exports tab. There should be at least one item in the left sidebar. In the right pane you see Custom Parameters and a plus button next to it…