Scripts does not work in M2 chip Mac Mini


I have installed Python 3.9 and 3.12. But I cannot see the 3.12 in my setting and seems my Glyphs doesn’t like it.

I have installed the pyobjc by following this thread

However, I still can’t use all the scripts. To give a clear report, the macro window looks like this

Is there any solution for this?

For best compatibility, install Python from WindowPlugin ManagerModules. Click the Install button next to “Python” and the relaunch Glyphs.

Then, go into the app settings (GlyphsSettings…Addons) and select the Python version ending in “(Glyphs)”. Relaunch Glyphs again and now the scripts should work.

Thank you for your reply,

I have already done that but I can’t find the Python version ending in ‘Glyphs’

Did you quit and relaunch Glyphs after installing Python from the Plugin Manager?

If you did relaunch and there is still no option ending in “(Glyphs)”, go to the Script menu → Open Scripts Folder. A Finder window will open. There, open the Repositories folder and have a look whether it contains a folder named “GlyphsPythonPlugin”.

If “GlyphsPythonPlugin” exists, delete it in Finder and then quit Glyphs. Then, try the installation steps again.

If “GlyphsPythonPlugin” does not exists, that would be very strange.

I found that folder in the Repo folder, however, it is empty.
I’ll do what you suggested again.

I was fail to install python by plugin manager so I just download and drag it into the script folder. Now I can see the python ending in Glyphs however, it ask me to install the python runtime again.

The installation can take a wile, maybe a few minutes depending on your internet connection. From the screenshot that you posted, the “GlyphsPythonPlugin” folder is still empty. Delete it and relaunch Glyphs. Then, install Python from the Plugin Manager and wait until the installation is complete. Only then relaunch Glyphs and follow the steps from above.