Strange Behaviour of Non Unicode Glyphs in Text Preview Tab

This feels related to this issue Preview offset not consistent across lines - #4 by oneweioranother

Not only is the position of the preview tab different to text tab, it’s as if where the text cursor is and where the preview tab thinks it is is inconsistent.

I have this string:

When I highlight a glyph and go into the background layer it should show the same result in the prevew tab as the edit view but it doesn’t (the background layers are all blank).

For example here, when I select / with the cursor, and go into the background layer, its the / that switches in the background in the preview tab. If I go into the /, it’s the /_part.six/_part.three that switches into the background in the preview tab. Strange.

Notice that when I remove the /a from the text tab, the preview tab position jumps.

Video Link

I fixed it.

Something similar to this is happening again but only after specific actions, I’ll try isolate it.

Basically sometimes when I go into the background layer, in the edit window, a glyph a few glyphs before the currently selected one goes into the background. If I move the carat left and right it correctly switches the currently selected glyph into the background but the preview panel still doesn’t update.