Text preview of complex scripts


#1

Hello,

Font preview doesn’t use the feature such as GSUB.

example ಕೋ
glyphs doesn’t display the right gsub (kKo in the font I am looking at)
instead displays
\uni0c95\uni0ccb

It would be great if glyphs can render the complex script knowing the feature definition.


#2

If your font has OT features defined, you should be able to preview them using the popup menu in the bottom left of the preview screen.


#3

Glyphs does preview GSUB, like Ben explained. What Glyphs cannot do is the job of the Layout Engine, e.g. reordering.


#4

if glyphs can call “hb-view” harfbuzz view in the background to preview the text.

It could be possible.

Also, Glyphs can add the ability to test the font in different shaping engine “coretext” “harfbuzz” …

here is unicode.org project that is built in python

Just an idea.

If you care to add it to glyphs, it would be great.

If you are expecting users to it themselves. I might pickup this task after I hit my milestone with the font work.


#5

You can do that already with TextPreview. Exporting without hinting and overlap removal is usually very quick, and TP updates instantly.


#6

Thanks, I will check.

My mistake, if I am asking obvious questions!


#7

For some reason, gsub is not working in text preview.


#8

See the red arrow in the bottom left? That means the OT features are not compiled. Go to File > Font Info > Features and press the Compile button.


#9

Glyphs previewing with Harfbuzz shaping is what the GlyphSILE plugin (in plugin manager) is for. But I think some people have problems getting it working. If you want to try and send me any error messages I would love to get it fixed.


#10

sure, where can I download it?


#11

It’s in the Plugin Manager.


#12

image


#13

found it on github


#14

The Plugin Manager can be found in the menu Window > Plugin Manager. That Preferences: Addons window shows the Plugins you have installed. fyi.


#15

OK. I will check that, I am not in front of the mac.

I am new to Glyphs.

So are there plugins preinstalled in glyphs?


#16

Some are pre-installed, most are not. Under Window > Plugin Manager you will find a list of the available plugins. You can pick and choose what best fits your needs. In addition, any time you open the Plugin Manager window after plugins are installed, if there are updates they get updated automatically.


#17

@SimonC I have installed the plugin.

It’s not drawing anything.

I have tried to compile the font feature. I have some trouble there.

But I have imported a font, which has all the right features.

Please check, if I am going wrong somewhere.


#18

This is great, thank you. It looks like you are doing the right thing but have found a problem with the plugin, which is what I wanted!

Please can you open the Lua Console window and the system Console application (open /Applications/Utilities/Console.app and type “Glyphs” in the search bar) and then hit “Draw” again, and tell me if any messages pop up in either of those windows.


#19
default 21:53:41.001217 -0500 Glyphs GlyphsSILE error running function `f’: attempt to call a nil value
default 21:53:41.006080 -0500 Glyphs UNIX error exception: 17
default 21:53:41.087681 -0500 Glyphs skipping upgrade for locked keychain /Users/sarathykr/Library/Keychains/Microsoft_Intermediate_Certificates
default 21:53:41.116870 -0500 Glyphs skipping upgrade for locked keychain /Users/sarathykr/Library/Keychains/Microsoft_Intermediate_Certificates
default 21:53:41.118061 -0500 Glyphs skipping upgrade for locked keychain /Users/sarathykr/Library/Keychains/Microsoft_Intermediate_Certificates
default 21:53:42.950385 -0500 Glyphs GlyphsSILE error running function `f’: attempt to call a nil value
default 21:53:49.530768 -0500 Glyphs 0x7fc53dd0e920 - PerformanceMonitor::measurePostBackgroundingCPUUsage: Process was using 9.1% CPU after becoming non visible.


#20

@GeorgSeifert After I installed glyphs, I am getting this microsoft certificate and keychain error.
we are seeing same error in console.
Please advise.