Thai vowels anchors problem

Hi thai’s developers! I am having issues to have working anchors in my font. I have added them all to the vowels, but the tone marks don’t move when I move the anchor. I used to latin and works fine, but in thai should I do something else to get it working?

18

For example here, when I move the top anchor at นึ่ง, the tone maiEk-thai didnt move.

Thanks a lot!

More examples, the first 2 glyphs with vowels/tones seems to be fine, but the last one, the ‘m’ looks too far from the ‘–’. The problem is that anchors are not responsive for this situations.

32

any tip?

Thanks!

Looks like the anchors are not linked with anything!

Glad to see new Thai typefaces in development!

For this kind of problem, we’ll need to know exactly what your anchor scheme looks like. What anchors do you have on a) consonants, b) marks above and c) upstairs marks above?

I recommend you use the Mark Preview plugin, that shows exactly the positions of marks relative to bases and each other.

EDIT: in your last screenshot, that situation with maiTri can be resolved by moving the top anchor on saraI down, then all upstairs marks can sit a little lower, if that’s what you prefer.

Hi @Bendy thanks for your answer. I am not using anchors in my consonants, just a top, _top in vowels and in tone marks. Here are some screenshots.

I understand that moving anchors should work and fix the distance issues, but I am unable to get my anchors to work. When I moving them, the diacritics didnt move at all.

10 32 11

When you say they ‘didn’t move at all’, where are you testing this, where expecting to see them move? The Mark Preview plugin, and the mark cloud in your images do normally show movement if the outlines or anchors are adjusted. Things to check:

  1. Make sure all marks are defined as marks: in the main window, select all marks, press cmd-alt-i and set the category ‘mark’ (and Thai, of course)
  2. I don’t know what anchors you have on your upstairs marks (maiEk-thai.small, maiTho-thai.small etc) but they all need “_top” so that they attach to the “top” anchors on your saraI and its friends.
  3. You will need anchors on your consonants. Without those anchors, the “_top” anchors on your marks are useless. Anchors have to be defined in pairs, so that marks are positioned correctly when they coincide.

Thanks Bendy.

  1. Didn’t know about this, thanks. Just did it.
  2. I have _top anchors on these. However when I type ตั่ง for example, it looks like maiTri-thai.small is not there but maiTri-thai (see screenshot).
  3. Ok, all setted.

I am looking at other fonts, open source fonts, and I see that the ‘diacritics’ overlaps or are in not intentionally wrong places

The Glyphs edit view is not doing any mark positioning. So you need to test it outside of Glyphs.

Same results using Illustrator

How are you testing:
https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems
https://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

Yes, I am using Adobe Fonts folder… Exported Prompt (https://fonts.google.com/specimen/Prompt?subset=thai) inside adobe fonts folder and I see this in Illustrator
18

It’s probably a good idea for you to read this other recent thread about Thai: [Thai script] combining marks. Especially the parts related to Asian script options in Illustrator, and the parts about defining OpenType substitutions to select the correct version of marks.

As Georg says, the Glyphs Edit view is not a preview of live, correctly shaped text, but a place for you to edit the glyphs. That’s why I recommended the Mark Preview plugin, it shows exactly where the marks will end up when anchored in the defined positions.

Thanks, I am reading that thread - lots of stuff going on!

I want to have a real test of the script in Illustrator. I followed this guide:
https://helpx.adobe.com/illustrator/using/asian-scripts.html

However, in my paragraph panel, I have only this options:
24

I don’t see thai or southasian script anywhere…

Also, there is no Thai in the language dropdown from Character panel
40

I’m afraid the Adobe apps are not very helpful when it comes to the Southeast Asian scripts, they don’t even have options for the national languages, far less any minority languages. I’ve been talking to various members of the different Adobe teams for about nine years so far, with only very limited success. The language options determine hyphenation, and would be used for spell-checking, so that’s not the current problem for you.

If you’re on Windows you might need to install the ‘language packs’ it mentions at the top of that page.

In Preferences, you tried ‘Show Indic options’? I think that’s probably what it needs.

Yep, I am on Mac, so I’ve omitted the language packs.
Thanks, using Indic worked. I’ve tried with East Asian :man_shrugging: now it seems to show tones using the anchors as expected to work…

1 Like

I am having trouble properly aligning these tonal marks. They are inverted in my font and I can’t find the cause of this. I have, for example, nikhahit_maiEk-thai and it contains the correctly placed components but apparently the font is using other components and place them in the wrong position? I can’t figure out the problem here. Also, the OT features are automagically generated, so I think are doing the job needed.

Do you have the World-Ready Composer turned on?

How are you typing these? Normally in Thai we have to type the tone mark before the saraAm, and then the shaping engine will reorder things correctly. What that means is your nikhahit_maiEk-thai should actually be maiEk_nikhahit-thai.

On that subject, what is the reason you’ve made those ligatures of marks? It’s much more straightforward to just have a top anchor on the nikhahit and let the tone marks attach to it in the normal mkmk way.

Ahá! Inverting the name does the trick! I don’t know why I have those like that, may be a copy paste from other font.

I have both ways to build it, with a double tone and simple tone… Thai people like both ways I think? I just wrapped my head around thai in a formal way… I don’t know the language :frowning:

It should work now, thanks again @Bendy

1 Like