The document "Xxxx.glyphs" could not be opened

I lost a file I created from a duplicate that I worked on all yesterday. I also tried opening a Glyphs file of the same thing 20 minutes before closing yesterday using TimeMachine.
The reason stated is: Invalid Point definition on line 2555

Always use a versioning system like git.

Could you open the glyphs file in a text editor like Sublime Text and copy the ~20 lines around line 2555? You can paste the code here by wrapping it in a block with a line ``` before and after, like so:


I’m sorry, but I have no idea what this means. I’m not a coder and have never used git.

Can you send me that file?

Where would line 2555 be located? What are these lines?

If you right-click or ctrl-click on the .glyphs file in Finder, you can choose to open it with a text editor instead of Glyphs, and you will find that .glyphs files are actually text files.
It would be handy if the text editor you choose has a line numbering feature to more quickly located the problematic parts of the file.

Thanks for the help. I have sorted it now by entering 0 instead of the really long number. The problem is now that I don’t know what it refers to in the font. It must be something minor as everything seems OK.

That are postscript hints that get disconnected.