Too many kerning pairs


#1

Hello there,

I’m preety new to the whole subject, so please excuse my question … I created a font which is quite big. language support from greenland to russia, full set of smart caps, tons of ligatures and of course, i get the

GPOS feature ‘kern’ causes overflow of offset to a sub

table

message while exporting. is there any possibility to fix something or do i have to cut the font into maybe three with a regular, a small caps and a ligatures set? the kerning/metrics are from igino marini and it would be a pity to loose that quality …

thank you in advance
flo


#2

The one thing you can do is to use kerning classes as much as possible, even if the class ends up with only one member. If you add classes after you added the kerning, you need to run the compress command from the gear button in the kerning window.


#3

already did that. maybe it’s just to huge. we’re talking about 3600 glyphs. but thanky you


#4

How many kerning pairs do you have?
In Glyphs 2 there is one option to activate ‘Extension Kerning’. That saves the kerning in a different way that might not work in all apps (my testing found no problems so far).


#5

3699 pairs …


#6

found that about the limit:

Technical background: Each pair in the “kern” table takes 6 bytes, there is a 14-byte header, and the maximum size of a subtable is 64K bytes, so (65536-14)/6 gives you 10920. Most font engines only support a “kern” table with one subtable, so there’s the limit.

so the kerning classes will add high?


#7

but i can export an earlier version with 3600 glyphs and even 7000 kerning pairs. but that was before iKern/mr. marini


#8

Can you send the font to: support (at) (this website without www), please.


#9

The number of kerning pairs gives only an estimate it the font will export or not. Because if you have a pair between a class and a single letter, there will be a pair for each member of the class. Thats why I suggested to add a group to each glyph.


#10
Glyphs does not export a kern table. It exports a kern feature in the GPOS table. The biggest difference is that the kern feature support classes that can reduce the number of needed pairs.

Old-style kern table export
#11

garamond premier pro has 2k + glyphs and 10k + pairs … there must be a way


#12

… well – opened it in glyphs but export didn’t work either.


#13

There is a way. It is call Extension Lookup. This is used by the big Adobe font. There is a custom parameter to enable this in Glyphs 2.


#14

But first try to optimise the kerning to get it to work without.


#15

will do that first. thank you. another topic hindering the workflow with iKern was the naming of the cyrillic set because »-« is »vorbidden« so i named them afiiXXXXX what worked out well. may i rename them again into nice names or is that a case for the otf police?


#16

You should never use the afii names. Use uniXXXX names instead. I speak with iKern to except hyphens in names.


#17

I sent the ikern files with further trouble description to support-at-website


#18

Thanks, will have a look.


#19

could you please tell me where to activate the ‘Extension Kerning’ in glyphs 2 (german)?


#20

There is a custom parameter in the instance settings.