(URGENT) Glyphs get shifted on export

Hi there, I’m working on a client font and opened an old OTF font in Glyphs. Everything looks good inside, but on export I get this:

If I open an old TTF font and export it, I get this:

I can’t use the TTF font, because the unit size is 2048 and it got converted to 1000 Em in 2011.

What could cause this issue? Does anybody have an idea on this?

Where do you get this?

This might be a font cache issue: Eliminating font cache problems | Glyphs

I got this after exporting the font to my desktop. I don’t use Adobe anymore so I have to test fonts differently.

I see the shifted glyphs in the file preview on Mac! Even before I installed it, so this should not involve font caching, right?

In the original font were some settings:

  • unicodeRanges
  • codePageRanges
  • glyphOrder
    But if I turn them off, the result is still the same. Bad.

Can you send me the .glyphs file?

1 Like

It’s in your mailbox.

False. Finder previews are cached. And they are no means for testing a font.

Consider FontGoggles, or a web-based solution, like the HTML scripts or wakamaifondue.com or fontgauntlet.com.

I see! So Finder is the problem? I saw it in the preview (use the tab to preview a file), but it also turned up in Font Book, so the preview was correct.

I deleted all the font caches with your method above. I exported the font again and dumped it on the websites mentioned above. This seemed to work well. The output now looks great. And I even get way more information than I got before. So fantastic.

I even found a very interesting way of testing font files in NON-ADOBE or NON-APPLE apps like Affinity Publisher. I’ll describe it in my forum post with that question:

It requires the use of Eagle app, but it works awesome. It seems to avoid font cache issues completely.