URGENT! Kerning Lost Its Mind

LOOOOOONG story short, I had my capitals only font 99% finished, installed it via FontBook, it worked great in Silhouette Studio, decided to try to duplicate the upper cases as lower cases, kerning didn’t duplicate with them, tried grouping them into kerning groups, didn’t work, deleted the lower cases, removed the kerning group labels, adjusted a little kerning here and there, uninstalled the first font in order to install the one with the updated kerning, exported, and kerning is no longer there for some letters. Removed all versions of the font from my computer, cleared my font cache per the Glyphs tutorial, kerning is still not there when I reinstalled after exporting again. When I open the kerning window, A-E (the letters I had grouped with lowercases in an attempt to get them to have the same kerning) have 2 versions: one with an @ before the letter, and another that seems like the actual letter and kerning I want. I have NO idea how to remove the @ version, but I think that would fix my problem.
(P.S. This is the first font I’ve ever made and the first font program I’ve ever used. Please word your answers as though you’re walking a 10 year old through the process. I don’t know all the lingo, shortcuts, etc. TIA!!!)

Why urgent? Today is the last day of my free trial and this headache showed me that creating fonts is NOT for me. This will be my first and last and I just want to use the font I made that is completely finished. :cry:

When you install a new version of a font in the system, make sure you understand this: https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Please read the kerning tutorial.

And do NOT install the font in the system until the font is finished. Use the Adobe Fonts Folder or the TextPreview app.

I already cleared my cache using that tutorial prior to posting and it did not fix the issue. It is not a cache issue, but the font exporting with those secondary kerning groups issue.

I read the kerning tutorial many times before beginning kerning and while trying to create kerning groups. I also watched the video tutorial and tried to follow it step by step as I tried to make the groups (kerned the A, duplicated the A and made it the a, selected both and changed their font group to A, a still did not kern, deleted the a. Now there is an @A font group listed in the kerning window) I do not have Adobe Photoshop or Illustrator. The TextPreview app link you shared is a broken link (Oops! That page doesn’t exist or is private.) The only text application I have pre-installed on my Mac is TextEdit, but that doesn’t show fonts.

What I need to know now is how to remove the @ font groups. Thank you for all your help!

Ok, now I’m really frustrated. I figured out how to delete those extra kerning groups. I deleted/removed all copies of the font from my computer, fontbook, etc. I cleared my cache per the Glyphs tutorial (again), and restarted my computer. I renamed the font family in an attempt to further remove any kerning cache issues. I exported the font, which looks like it’s absolutely perfect and exactly as I want it. It STILL isn’t kerning in applications.

So now what?

Which apps are you testing in?

Here is the proper link for the TextPreview, sorry: https://glyphsapp.com/tools/textpreview

Removing kerning groups: select all glyphs, then click in Left Group, type a space and delete it right away. This sets it to empty. Do the same with Right Group, then clean up kerning in the gear menu of the Kerning window.

I do not think that the problem is that you have groups. Rather that (a) the groups are not properly applied to both lowercase and uppercase, and (b) it looks like kerning was not compressed properly. The screenshot shows that the left halves of your kern pairs were compressed into groups, but not the right halves, which still remained single glyphs. I would recommend to compress properly: make sure all groups are set, and compress twice so that both sides of all kern pairs are groups.

The way it looks in your screenshot is that left halves are groups, but right halves are uppercase letters only.

I do not understand what you mean by this. How do you know that the Kerning is not working if you do not have fonts in TextEdit and there is no other text app?

I downloaded TextPreview, but it will not let me select the drop down bar to change the font, as though there are no fonts.

All of my left and right kerning groups are already set to empty. Each glyph is individually kerned.

The font is only uppercase and I have no lowercase glyphs any longer and don’t even want to try messing with them at this point. I will be happy if my uppercase only font exports with the correct kerning, as it did before I tried duplicating the uppers as lowers.

Kerning is not working when I install the font and use it in Silhouette Studio, Open Office, or Pixelmator. Those are the programs I use with various fonts and for designing. The first time I exported and installed, before messing with lowercases, the kerning worked just fine in Silhouette Studio. After clearing cashes, removing the font from everywhere, deleting the lowercases, fixing the kerning groups, etc, the kerning no longer works when I try to use the font in Silhouette Studio.

Thank you so much for your help. I’m about to cry over this, after putting so much work into it and being finished, but unable to use it properly.

The glyphs are gray because they’re selected so as to show the kerning groups on the left hand side, not because there are unsaved changes.

The kerning shows up properly in Glyphs

The point of the app is that you do not need to install fonts but can set a folder that TextPreview watches. Press Cmd-comma, set a watch folder and export into that folder from Glyphs, and test the font inside TextPreview. If it works there, then you know there is no problem with the font in CoreText, but the problem lies within the apps you are using. Prefs? Kerning enabled? App caches? Can be anything.

Can you send me the .glyphs file please to support (at) (this website without www). I will have a look, but won’t get around it until tomorrow.

I set the folder to where the font is (it’s the ONLY file in that folder), but it did not bring up the font. :confused:

Restart TextPreview.

I will happily send it to you to look at, but with my trial expiring tonight, I’m worried I’ll lose the whole thing and have to purchase the application just to recover this one, completed font. I have ZERO interest in ever making another font, after all this mess.

I JUST re-exported it and restarted TextPreview and it popped up in TextPreview and the kerning IS working!!! That should mean if I install the font, it should work in all of my applications, right???

That means your font is fine. If an app does not display it properly, it is not your font’s fault. Any app using CoreText should be able to display it, unless you disabled kerning.

Save your font file. An expiring trial does not mean your files are deleted.

Disabled kerning would be done within Glyphs, right, not the other application?

Kerning is ON in Silhouette Studio, but it is not kerning properly.

Your font file is fine, Glyphs exported it properly with kerning intact. I don’t know silhouette studio, but it looks like it is not using CoreText for rendering. If it is not capable of displaying kerning, you will have to get support from the people making that software.

Also not working in OpenOffice

I have over 1k fonts and have never had one not kern in any of those 3 applications before. Why would they kern all other fonts but not this one? Does OTF vs TTF matter? I exported and downloaded it as an OTF, like I do every font with that option.

Also, I’ve reached my maximum allowed posts for a new user in this forum for one day, so I’m not able to reply to your responses. Thank you SO much for your help!!! I’ll try deleting everything again, clearing the cache, and downloading as TTF and report back here at the bottom of this response since I can’t post a new one. Hopefully you see this edit.


Deleted all copies of the font, removed from fontbook, emptied trash, cleared cache, restarted computer, renamed font family, exported as a TTF, checked with TextPreview and kerning was fine, installed, kerning still NOT working in Silhouette Studio, OpenOffice, or Pixelmator.

EDIT in response to @GeorgSeifert
I really hope you guys are seeing these edits since I can’t make any more posts. :confused:

When I clicked “update” in the feature tab, this showed up “languagesystem DFLT dflt;”. I’m assuming to test if that fixed the issue I need to delete all copies of the font, clear the cache, restart, export, and reinstall again?

May also be a cache problem again, change the font family name, reexport, install. I seem to remember OpenOffice prefers TTFs. You may want to try the TTF export option.